[Can't confirm] Mouselook bug

Bugs that have been investigated and resolved somehow.

Moderator: GZDoom Developers

Forum rules
Please don't bump threads here if you have a problem - it will often be forgotten about if you do. Instead, make a new thread here.
Anonymous

Mouselook bug

Post by Anonymous »

I am experiencing a bug in ZDOOM 20.52 which involves the mouse. I am playing with freelook OFF, in other words I cannot look up and down but use the mouse to turn the player only. I use the UP and DOWN arrow keys to move forwards and backwards, and I use the LEFT and RIGHT arrow keys to strafe left or right. In previous versions of ZDOOM this worked fine but now if I try to move the mouse forward or backward, the screen stutters as if the character is trying to look up and down (or move forward) but is being stopped repeatedly. This makes the game somewhat less enjoyable due to the fact that any little forward movement of the mouse I may inadvertently make while playing will trigger this bug. Any help on this would be appreciated.
User avatar
Biff
Posts: 1061
Joined: Wed Jul 16, 2003 5:29 pm
Location: Monrovia, CA, USA

Post by Biff »

Zdoom 52 has an enhanced menu for the mouse. Go into Options, Mouse Options and set the Forward/Backward Speed slider all the way to the left.

This stuff used to be accessible through console commands, probably still is. If you type m_forward in the console and hit Enter, Zdoom should report the current setting and it's probably 1 by default. Then you can set m_forward 0 or a small number, or just do it through the menus. Hope that helps. I tried to duplicate your problem but actually could not.
Anonymous

Thanks

Post by Anonymous »

Hey Biff, thanks for the info man. I appreciate you taking the time to respond. By the way, I like your Caleb icon. Is it just me or do his eyes flicker a little bit? Pretty rad.

-Morthore
User avatar
Hirogen2
Posts: 2030
Joined: Sat Jul 19, 2003 6:15 am
Github ID: jengelh
Operating System: RedHat-like Linux (RHEL, Fedora, CentOS, etc) 64-bit
Graphics Processor: Intel with Vulkan Support
Location: Central Germany

Post by Hirogen2 »

Really.... it's the graphics that flicker.
User avatar
cccp_leha
Posts: 1816
Joined: Wed Jul 16, 2003 7:21 am
Location: NJ, USA

Re: Thanks

Post by cccp_leha »

Morthore wrote:...By the way, I like your Caleb icon. Is it just me or do his eyes flicker a little bit? Pretty rad.

-Morthore
His heart is also visibly beating.
User avatar
Biff
Posts: 1061
Joined: Wed Jul 16, 2003 5:29 pm
Location: Monrovia, CA, USA

Post by Biff »

Heh, yeah, I made his eyes brighten occasionally and I also gave him a Doom2 heart transplant!
User avatar
HotWax
Posts: 10002
Joined: Fri Jul 18, 2003 6:18 pm
Location: Idaho Falls, ID

Post by HotWax »

Biff wrote:Heh, yeah, I made his eyes brighten occasionally and I also gave him a Doom2 heart transplant!
:lol: Nice work, I didn't even notice it before. Nice 'n' subtle.
User avatar
Malphas
Posts: 33
Joined: Wed Jul 16, 2003 2:14 am
Location: The Ultimate Warzone (Bronx, NYC)

Post by Malphas »

"God and the Devil are in the details."

:P
User avatar
randi
Site Admin
Posts: 7728
Joined: Wed Jul 09, 2003 10:30 pm

Post by randi »

I cannot reproduce the problem. Tested using ZDoom 2.0.48, 50, 51, and 52 with in_mouse 1 and 2 and cl_capfps true and false.
Kuroshi
Posts: 68
Joined: Fri Oct 31, 2003 4:40 pm

Post by Kuroshi »

I thinks Biff's suggestion could work. In my case, if my mouse moves too much in one tic the cursor or view will stutter. Like Biff suggested, try turning down the sensitivity on the offending axis and possibly the acceleration in Windows.

EDIT: Should have tested this first, actually the problem seems to be the mouse INPUT being too high from moving it too fast (I actually have a Kensington trackball mouse). Not the speed the cursor or view moves. So in actuality, try turning your Windows acceleration up a bit. I'm pretty sure this is not a ZDoom bug.

Return to “Closed Bugs”