GZDoom Script Error on a WAD

Sat Oct 09, 2021 11:26 pm

I am having a script error when trying to load this WAD on GZDoom. I've never gotten an error like this before on any other mods I have run.
Here is a download for the WAD I am having the error with:
https://archive.org/details/abyssal_anti-social



Script warning, "anti-social.wad:DECORATE" line 273:
Tried to define class 'Plant12' more than once. Renaming class to 'Plant12@anti-social.wad@DECORATE'
Script warning, "anti-social.wad:DECORATE" line 596:
Tried to define class 'CONE' more than once. Renaming class to 'CONE@anti-social.wad@DECORATE'
Script warning, "anti-social.wad:DECORATE" line 9:
Icon 'CLP1C0' for 'AR15Clip' not found

Script warning, "anti-social.wad:DECORATE" line 153:
Tried to define class 'Clip' more than once. Renaming class to 'Clip@anti-social.wad@DECORATE'
Script warning, "anti-social.wad:DECORATE" line 567:
Tried to define class 'GlassShard' more than once. Renaming class to 'GlassShard@anti-social.wad@DECORATE'
Script warning, "anti-social.wad:DECORATE" line 598:
Tried to define class 'LightPosts' more than once. Renaming class to 'LightPosts@anti-social.wad@DECORATE'
Script warning, "anti-social.wad:DECORATE" line 251:
Icon 'CLP1C0' for '9mmClip' not found

Script warning, "anti-social.wad:DECORATE" line 488:
Icon 'CLP1C0' for 'SGClip' not found

Script warning, "anti-social.wad:DECORATE" line 491:
Tried to define class 'Shell' more than once. Renaming class to 'Shell@anti-social.wad@DECORATE'
Script warning, "anti-social.wad:DECORATE" line 674:
Icon 'CLP1C0' for 'MP5Clip' not found

Script warning, "anti-social.wad:DECORATE" line 677:
Tried to define class 'Clip' more than once. Renaming class to 'Clip@anti-social.wad@DECORATE'

Execution could not continue.

Script error, "anti-social.wad:DECORATE" line 677:
Script error, "anti-social.wad:DECORATE" line 677:
Tried to define class 'Clip' more than twice in the same file.

Re: GZDoom Script Error on a WAD

Sun Oct 10, 2021 12:37 am

That mod is broken. It redefines internal actors and then runs into problems. This won't work anymore with anything post ZDoom 2.8.1.

Re: GZDoom Script Error on a WAD

Sun Oct 10, 2021 12:42 am

Graf Zahl wrote:That mod is broken. It redefines internal actors and then runs into problems. This won't work anymore with anything post ZDoom 2.8.1.

Would it work if I download an earlier version of ZDoom?

Re: GZDoom Script Error on a WAD

Sun Oct 10, 2021 12:48 am

Like I said, it should still work with ZDoom 2.8.1 or early GZDoom 2.x versions. But you still may run into problems with savegames - this was the reason the code was changed.