gzdoom massive slowdowns

Thu Jun 24, 2021 8:07 pm

Help, gzdoom running horribly slow. Video card downclocks to 200Mhz, which I thought was a driver issue, but it's not. I found a way to force clocks up, but it doesn't help much, and supposedly it does this when the game isn't using the graphics enough.

I'm using gzdoom 4.6, smoothdoom, voxels, with eviternity. Performance just tanks in large areas.

System:
Windows 10
Ryzen 3700x
Vega 56

edit: I think it's the voxels. Is there any way to optimize voxel performance? Seems like hidden surface culling is not enabled. If not in the engine, has anyone made a performance patch for the voxels like: https://www.youtube.com/watch?v=7D9UUMB5J4Y