Absurdly low frames on GZDoom 4.5 OpenGl

Sat May 08, 2021 12:22 pm

I've been having this super weird issue with GZDoom 4.5, whenever I use OpenGL there's this huge lag in my game and I get about a frame per 5 seconds. I can't even do such a simple task of browsing through the menu on the titlescreen without waiting for a good 5 or 6 seconds for each press without any mods. This only appears with 4.5, I tried playing with 4.4.2 on OpenGl again and it works fine. I tried using Softpoly, it works fine but it's not running quite well as OpenGl normally would. I've even tried one of the dev builds and the same delay is there on OpenGl too. And I've also recently tried updating my driver but nothing has changed. Could anyone please help? My OpenGl version is 4.0 and my graphics driver is Intel(R) HD Graphics, if that helps.

Re: Absurdly low frames on GZDoom 4.5 OpenGl

Sat May 08, 2021 1:03 pm

If changing gl_control_tear didn't help try with gl_finishbeforeswap.

Re: Absurdly low frames on GZDoom 4.5 OpenGl

Sat May 08, 2021 2:02 pm

Just tried it, seems to be fine for now but not really sure if it is permanent, because sometimes it seems to have been fixed by itself, but still does go back to the state it was eventually after restarting the device.

Re: Absurdly low frames on GZDoom 4.5 OpenGl

Sat May 08, 2021 2:17 pm

Sorry! Posted the message above on another device, forgot I was logged of on that one.

Re: Absurdly low frames on GZDoom 4.5 OpenGl

Sat May 08, 2021 3:55 pm

Well, the issue has occured again after restarting the device. Tried it, didn't help too.