I Cant play doom 2 IWAD compatible wads on gzdoom

Sun Apr 25, 2021 6:49 am

Exactly what the title says. i cant play wads/mods that need the doom 2 iwad. Whenever i drag n drop wads/pk3s like sunlust,ancient aliens etc. it automaticaly chooses The ultimate doom as the iwad.
I have no idea what changed that gzdoom does this. It originaly gave me the IWAD selection window but now it doesnt show crap and i dont know how to fix it. Does anyone have ideas?
If you cant tell im relatively new to Gzdoom and modding in general.

Re: I Cant play doom 2 IWAD compatible wads on gzdoom

Sun Apr 25, 2021 7:29 am

Perhaps you've accidentally disabled the IWAD selection window? The wiki has several methods to bring it back if needed.

Re: I Cant play doom 2 IWAD compatible wads on gzdoom

Sun Apr 25, 2021 8:37 am

Use dedicated launcher. There you can choose what mods/maps/etc. should be loaded with what iwad and in what order.

For example ZDL
https://zdoom.org/wiki/ZDL
It works for all Doom source ports (Gzdoom Zdoom, Boom, Prboom, I lack fantasy-oom)

Tutorial how to use ZDL
viewtopic.php?f=39&t=72099