GZDooM Runs at Standstill Pace After Win 10 Update

Fri Apr 16, 2021 1:09 pm

I recently decided to update/upgrade my computer's operating system to v20H2 (OS Build 19042.867). In all other ways the update/upgrade works fine. But GZDooM is unplayable. For example, when I start a new game the screen melt at the beginning takes 2 minutes 50 seconds. I used vid_fps 1 in the console to get the frame rate, and it's showing zero. See screenshot below.

I am using a hot-fix version ginned up by drfrag last year in response to an OpenGL issue I was having when I upgraded from Win 7 to Win 10. That version ran fine until I upgraded Win 10 to v20H2

I tried running GZDooM with no command parameters, as well as the following ones that Rachael suggested, but the result is the same:

gzdoom +vid_preferbackend 2 +vid_scalemode 1 +vid_scalefactor 1 -iwad doom2

As a point of reference, LZDooM runs just fine.

[EDIT: drfrag sent me a PM that indicated this is a known problem. MS drivers didn't come with OpenGL support. I will try to get & install the drivers from intel, but I'm sure it won't be easy. Any suggestions for the best way to get intel drivers for an old graphics chipset?]

GZDooM 0 FPS.jpg
You do not have the required permissions to view the files attached to this post.

Re: GZDooM Runs at Standstill Pace After Win 10 Update

Fri Apr 16, 2021 2:00 pm

I used the IntelĀ® Driver & Support Assistant and it tells me: "No supported driver or software updates are available for your system." It detects the driver version is 9.17.10.4459, dated 5/19/2016. I independently confirmed this by using Settings to check the Display Adapter Properties.

In other words, I must have misunderstood drfrag's explanation to mean the MS Windows update replaced my original intel drivers with drivers having no OpenGL support. This also tells me that the drivers may not be what are causing my insane slowdowns in GZDooM.
Last edited by ReX on Sun Apr 18, 2021 8:46 am, edited 1 time in total.

Re: GZDooM Runs at Standstill Pace After Win 10 Update

Fri Apr 16, 2021 2:24 pm

Mind if I ask you what are your system's specs?

Re: GZDooM Runs at Standstill Pace After Win 10 Update

Fri Apr 16, 2021 2:47 pm

This happens to me a lot actually. What I normally do is exit the game, and then do a restart (not shut down), after that it usually works. Not sure if that'd be the case for everyone though.

Re: GZDooM Runs at Standstill Pace After Win 10 Update

Fri Apr 16, 2021 3:41 pm

Try this version:

https://cdn.discordapp.com/attachments/ ... 599bb28.7z

It was compiled from this branch: https://github.com/emileb/gzdoom/tree/b ... 62917d8fcd

No guarantee that it'll be better, but it might be. Please try with a fresh .ini if it is too slow. (Possibly regular GZDoom too)

Re: GZDooM Runs at Standstill Pace After Win 10 Update

Fri Apr 16, 2021 9:05 pm

electrodragon554 wrote:Mind if I ask you what are your system's specs?

Processor: Intel(R) Core(TM) i5-2410M CPU @ 2.30GHz 2.30 GHz
Installed RAM: 8 GB
System Type: 64-bit operating system, x64-based processor
GPU: Intel HD 3000

The thing is, my system was running GZDooM fine on the day before the Windows update, and got messed up immediately after the update. This is clearly not a system specification issue. Similar shit happened when I upgraded from Win 7 to Win 10 a year ago. Except, at that time I couldn't even get GZDooM to run at all.

Xim wrote:What I normally do is exit the game, and then do a restart (not shut down), after that it usually works.

I restarted my computer after a subsequent Windows update, but that didn't make any difference.

@Rachael: I've downloaded the version you pointed to, and I'll give it a shot. Thanks.
Last edited by ReX on Fri Apr 16, 2021 9:41 pm, edited 1 time in total.

Re: GZDooM Runs at Standstill Pace After Win 10 Update

Fri Apr 16, 2021 9:20 pm

ReX wrote:
electrodragon554 wrote:Mind if I ask you what are your system's specs?

Processor: Intel(R) Core(TM) i5-2410M CPU @ 2.30GHz 2.30 GHz
Installed RAM: 8 GB
System Type: 64-bit operating system, x64-based processor

The thing is, my system was running GZDooM fine on the day before the Windows update, and got messed up immediately after the update. This is clearly not a system specification issue. Similar shit happened when I upgraded from Win 7 to Win 10 a year ago. Except, at that time I couldn't even get GZDooM to run at all.

One of the most important things about this question is the GPU. But I was able to figure that out from the processor, and from you mentioning Intel drivers before. It is an Intel HD 3000.

Re: GZDooM Runs at Standstill Pace After Win 10 Update

Fri Apr 16, 2021 10:19 pm

Rachael wrote:One of the most important things about this question is the GPU. But I was able to figure that out from the processor, and from you mentioning Intel drivers before. It is an Intel HD 3000.

Yes, I forgot to originally include that information. I've edited to include now.

To update on my GZDooM version tests: I was able to run Emile B's version as well as the official v4.5.0 version, but only using the command line parameters you had sent me for a batch file [gzdoom +vid_preferbackend 2 +vid_scalemode 1 +vid_scalefactor 1 -iwad doom2]. Neither version runs with just compatibility mode set for Windows 8.1; I get the "R_OPENGL: OpenGL driver not accelerated" error.

In addition, I am unable to adjust the game's resolution in the Set Video Mode. I can scroll to the relevant setting, but it does not modify the resolution - it remains at 711 x 400. The same with the Preferred Rendering API, which returns to SoftPoly. In other words, my options appear not to be getting registered.

Bottom line is that I am able to run GZDooM again, but only using the parameters you had sent me. Using it in this way creates some limitations that I can probably live with. But would I be better off just using LZDooM on this particular computer?

Re: GZDooM Runs at Standstill Pace After Win 10 Update

Sat Apr 17, 2021 12:18 am

The options I sent you do indeed set softpoly as well as a number of scaling parameters to run it more smoothly. Your system should be more than capable of handling it, it was merely a diagnostic and to get you on your feet.

Try Emile B's version with OpenGL (+vid_preferbackend 0). You may have to set Windows 8.1 compatibility. Please let me know how that runs.

Also make sure to set the scaling modes to normal (+vid_scalemode 0 +vid_scalefactor 1) to determine if this runs at an acceptable frame rate.

A quick documentation if you want to know what the options I keep giving you do:
Code:
: vid_preferbackend [int 0 - 2]
0 = OpenGL
1 = Vulkan
2 = Softpoly

: vid_scalemode [int 0 - 6]
0 = Default (determined by window size)
1 = Reduced (reduces the window to 640 wide or 400 tall, whichever is greater, meant for softpoly and for GPU's with bad pixel fill rate or reduced cache)
2 = 640x400 (with tall pixels, emulates a high-res variant of 320x200)
3 = 960x600 (same as above)
4 = 1280x800 (same as above)
5 = Custom Scale (use the 'vid_setscale' ccmd to set this mode)
6 = 320x200

: vid_scalefactor [float >0.0 - 2.0]
Takes any non-zero float value 2.0 or below to modify vid_scalemode. Applies this value to the final resolution. Resolution will always be at least 320x200 no matter what, and will always be at least 640x400 when menu or console is active

Re: GZDooM Runs at Standstill Pace After Win 10 Update

Sat Apr 17, 2021 3:49 am

There's a lot of false information on this matter even from intel, my guess it's that the windows update replaced your driver with the one from Monkeysoft without OpenGL support and intel never released win 10 drivers for your "card". That tool is not reliable, you need to install manually the win 8.1 driver for your card, may be you even need to do it on win 8 compatibility mode. Then you'll need to run LZDoom on that compatibility mode too, i guess you're running LZDoom on software mode so you should choose OpenGL. Or use the GZDoom vintage build but that's older, that card never supported GL 3.3 on windows.
Beloko's ZDoomGLES will probably run on GL 3.1 you should try as Rachael said, may be it's even fast. You'll need to set the compatibility mode too.
In any case you'll need to install the intel driver first.

Re: GZDooM Runs at Standstill Pace After Win 10 Update

Sat Apr 17, 2021 3:40 pm

@Rachael, I tried what you suggested, using the following command line in a batch file:

gzdoom +vid_preferbackend 0 +vid_scalemode 0 +vid_scalefactor 1 -iwad doom2

I also set compatibility to Win 8.1. GZDooM does not run, and returns the same fatal error I used to get: "R_OPENGL: OpenGL driver not accelerated.

@drfrag, you said: "... you need to install manually the win 8.1 driver for your card ... In any case you'll need to install the intel driver first." I can understand that the intel driver check tool is not reliable. But if it's telling me all is fine, how do I go about finding the appropriate driver on intel's site? At any rate, let me poke around and see what I can find. Thanks.

Re: GZDooM Runs at Standstill Pace After Win 10 Update

Sun Apr 18, 2021 3:32 am

I don't know but i just typed "intel hd 3000 driver" in google and it was the first result. Then i searched in the intel page "hd 3000" and i found this:
https://downloadcenter.intel.com/downlo ... =hd%203000

Re: GZDooM Runs at Standstill Pace After Win 10 Update

Sun Apr 18, 2021 7:18 am

drfrag wrote: i searched in the intel page "hd 3000" and i found this: https://downloadcenter.intel.com/downlo ... =hd%203000

I went to that page, but it is indicating the driver version is older than the one I have, It shows:

Version: 15.28.24.4229 (Latest)
Date: 6/5/2015

My computer's Settings show:

Version: 9.17.10.4459
Date: 5/19/2016

I don't know enough to mess with drivers, so I'll do some more digging to see how to get the original drivers I had (which allowed your hot-fix version of GZDooM to run).

Thanks, anyway.

[EDIT: I've been doing some reading, and I'm beginning to understand some of the technical explanations provided here and in the other discussion thread. It also turns out that someone else asked the exact question I asked in this post about version numbers and dates. F*ckin' intel. F*ckin' Microsoft.]

Re: GZDooM Runs at Standstill Pace After Win 10 Update

Mon Apr 19, 2021 12:29 pm

ReX wrote:I don't know enough to mess with drivers, so I'll do some more digging to see how to get the original drivers I had (which allowed your hot-fix version of GZDooM to run).

I did some digging, as I indicated, and it turns out that installing older drivers for Win 10 is rather straightforward. At any rate, what drfrag indicated was causing the problem (i.e., the Win 10 update installing newer, problematic graphics drivers) appears to be exactly what was happening. After I installed the Win 8.1 graphics drivers the hot-fix version of GZDooM runs just like before, even without Win 8.1 compatibility mode set. I'm now averaging about 150 fps on MAP01 of Doom2.

GZDooM 4.5.0 and Emile B's versions (as expected) still won't run unless I disable the OpenGL option.

Many thanks to everyone who helped and explained.

Re: GZDooM Runs at Standstill Pace After Win 10 Update

Mon Apr 19, 2021 12:43 pm

ReX wrote:(i.e., the Win 10 update installing newer, problematic graphics drivers)


I wished for the rest of us, remaining on Windows 7 (or even Windows 8.1) was still a viable option. It sounds like Windows 10 just keeps getting worse and worse. Especially for anyone on old hardware. Having to constantly fight with and kludge things in Windows 10 is such a annoying prospect.

I wonder if the reason why you have to install a Windows 8.1 graphics driver is because Intel doesn't want to sign a driver for Windows 10?

Just as a side thought, you might try running GZDoom in Linux (test with a LiveCD environment first), especially something based on a Ubuntu LTS release. (If you go with Ubuntu LTS you can easily install GZDoom with deb packages) Drivers for Intel graphics on Linux stretch back very, very far down the line. It shouldn't even matter what major linux kernel release you're on either. Though, you might expect trouble on Mesa 21.x.x because I've heard they've been trying to cut down on "legacy" code and move it to something else.

I used to have a Asus laptop that only had a Intel GMA 4500 and, for whatever reason, the Linux drivers did more than the Windows drivers wanted to try to do. (But this was a Windows 7 laptop, and really old)