Changed renderer to Softpoly, now crashes on startup

Wed Feb 10, 2021 4:15 am

GZDoom has always ran perfectly, for years, until today. I was playing around with the display settings and changed the renderer from OpenGL to Softpoly. after that it crashed, and every time I goto run GZDoom is always crashes. I have the latest version by the way. is there any way to fix this? I've tried uninstalling and and reinstalling and I still have the same problem. please help! thanks :?

on Mac OS X by the way.

Re: Changed renderer to Softpoly, now crashes on startup

Wed Feb 10, 2021 4:26 am

Post crash report please. Also, go to ~/Library/Preferences directory, and post gzdoom.ini file as well.

To switch back to OpenGL, add +vid_preferbackend 0 to command line options.

Re: Changed renderer to Softpoly, now crashes on startup

Wed Feb 10, 2021 4:37 am

thank you so much! I added that to the additional parameters and its working again!

Re: Changed renderer to Softpoly, now crashes on startup

Wed Feb 10, 2021 5:01 am

If you run GZDoom directly (not through a launcher), you should get a startup window where you can change the renderer.

Re: Changed renderer to Softpoly, now crashes on startup

Wed Feb 10, 2021 5:48 am

Works well on Windows. On Mac and Linux that window leaves much to be desired, I am sure. :)

Re: Changed renderer to Softpoly, now crashes on startup

Wed Feb 10, 2021 9:18 am

Aren't modern macs based on intel? I know there is a crash on arm due to a memory alignment problem, Beloko fixed it on clang using a linker flag but that one is not available on gcc.

Re: Changed renderer to Softpoly, now crashes on startup

Wed Feb 10, 2021 11:44 am

Not all macs are. Apple has begun a pullout from the Intel platform, completely.

Re: Changed renderer to Softpoly, now crashes on startup

Wed Feb 10, 2021 2:06 pm

In any case, no crash report means no fix.