Sound is stereo but MIDI doesn't play center pan

Wed May 17, 2017 11:46 pm

Ok this is a bit irritating... in FMOD settings for GZDoom 2.2.0 I have it set to stereo which is the way I like it to be so the game sounds are right, but for some reason it's making some MIDIs play off center and it sounds like it's coming from only one side of my headphones. If I switch it to mono, the MIDI plays center pan and sounds normal. I don't remember this being an issue in older GZDoom before I went to 2.2.0, namely 2.0.05.

Was this an issue that has since been resolved or did the way MIDIs are played get changed? I have noticed MIDIs in general sound a bit different from 2.0.05 to 2.2.0, somewhere in there.

Re: Sound is stereo but MIDI doesn't play center pan

Wed May 17, 2017 11:55 pm

What MIDI device is being used? Does it happen with all of them, or just specific ones?

Re: Sound is stereo but MIDI doesn't play center pan

Thu May 18, 2017 12:08 am

The actual setting for MIDI device is "sound system." Sound backend is FMOD. It seems to be only specific MIDIs that are off center now, whereas before all MIDIs were center panned.

Re: Sound is stereo but MIDI doesn't play center pan

Thu May 18, 2017 1:26 am

Nevander wrote:The actual setting for MIDI device is "sound system." Sound backend is FMOD.

Seems to suggest it's an issue with FMOD. Either that or FMOD is failing to play it and it's falling back to another MIDI device that's having trouble. Does it happen with other MIDI devices?

Re: Sound is stereo but MIDI doesn't play center pan

Thu May 18, 2017 2:39 am

2.2.0 uses a different FMOD version than 2.0.5. I hope you now get an idea why I wanted that library gone.

Re: Sound is stereo but MIDI doesn't play center pan

Thu May 18, 2017 11:49 am

Was the FMOD version in 2.2.0 the same in all releases following it until 3.0.0?

Re: Sound is stereo but MIDI doesn't play center pan

Thu May 18, 2017 1:31 pm

I think so, yes. That was the last one ever released before FMod Studio.