GZDoom 3.0.1 - sudden input problems

Wed May 10, 2017 7:58 pm

This is really frustrating. I was working on a new DECORATE script in Slade 3, saved the .pk3 file and ran the archive, but all of a sudden GZDoom's settings are made so the menu automatically comes up as soon as I run the WAD (as if I had pushed the start button,) and as soon as I start a game the player starts automatically spinning clockwise.

I highly doubt my script has anything to do with it - all it does is give a Zombieman enhanced speed and health and the ability to shoot Imp fireballs (following a tutorial on the DZoom wiki, I haven't made WAD in years and need to brush up on my DECORATE skills.) I am using a config file optimized for a USB game controller, that I am highly fond of. I noticed deleting the config seemed to make the problem go away, but it came back as soon as I copied and pasted a fresh copy of the same GZDoom config, thinking my script had somehow caused the problem.

Please help, this is really unfortunate that GZDoom starts glitching up as soon as I need it more than ever to test my WADs.

Edit: I may have just fixed the problem myself. It's possible GZDoom was reading input from both the controller I wanted and an Xbox 360 controller plugged into a different port, that had quite a bit of junk on top of it to possibly cause the start button and analog stick to make the player do that. Unplugged Xbox controller and game pad, plugged the game pad back in, reset the config just to be sure, copypasted it back in and changed a few things and now both it and my script seem to be working fine.

I'm still wary of something else going on, so I'm not quite ready to have the mods mark this as solved. What do you think?

Re: GZDoom 3.0.1 - sudden input problems

Wed May 10, 2017 9:22 pm

The symptoms alone sounded like a gamepad problem, whether just a gamepad with stuff sitting on it (as you described) or the joystick config reading the wrong axes (possible if a driver change happened recently, i.e. with a DualShock 4 or similar).

Re: GZDoom 3.0.1 - sudden input problems

Thu May 11, 2017 11:32 am

I am pretty sure it was caused by the other controller. I plugged it back in this morning and tested to see if GZDoom reads input from two plugged-in controllers at a time. It does, so the problem was almost assuredly caused by other stuff on my desk sitting on top of the controller.