Co-op Chex Quest

Sat May 23, 2020 12:12 pm

With the release of Chex Quest HD and its addition of multiplayer, my sister and I got very excited until we discovered that it's only deathmatch. Her birthday is coming up and I'm trying to figure out how to make chex quest work with co-op for her.

I started with chex quest 3, downloaded from the chucktropolis page. Testing with a friend, we ran chex3 from the command prompt ('chex3 -host 2' and 'chex3 -join [my ip]' from the respective game directories), but were unable to connect to each other. (Mine never went past 'Waiting for players 1/2')

I have looked in the router settings to port forward (, but can't get past step 3. I am able to set up port forwarding for TCP 5029, but when I try to set it to UDP it tells me 5029-5029 is an 'Invalid range of ports'.

('Invalid range of ports' -
(I did manage to set the port up for TCP -

We also tried the latest GZDoom ('gzdoom -iwad chex3.wad -host 2' and 'gzdoom -iwad chex3.wad -join [my ip]' from the respective game directories), which seemed to confirm that it is a network error, not a software error.

Reading the user manual for my Arris DG2470A did not provide me a list of acceptable ranges for UDP ports. Beyond picking one at random, I have no idea what range to try that it might accept. What should I try next?

From the Port Fowarding page troubleshooting: (I'm fairly certain we're good on 1 and 3)
2) How do I check that my firewall gives ZDoom server privileges?

Re: Co-op Chex Quest

Tue May 26, 2020 10:10 am

(I'm the OP, the first post didn't go while I was logged in)

I tried opening a random UDP port. My router accepted 666-666 as a range for UDP.

Unfortunately 'chex3 -host 2 -port 666' didn't accept traffic from either 'chex3 -port 666 -join' or 'chex3 -join'. I was stuck on waiting for players, they were stuck on connecting