Re: ZDoom Executor new ZDoom (and related projects) Frontend

Thu Apr 09, 2015 7:14 am

Devianteist wrote:I'll be sure to try out the beta. Yes it worked before, and I am using Windows 7 on both computers that this problem has arisen on. It's baffling as to what may have happened, too, cause it was working fine earlier the day I posted something about it here.

EDIT: Problem solved. Still confused as to what happened, but at least it's working again. :shrug:


Well, it is odd, indeed, but I'm glad it's working again :)

Re: ZDoom Executor new ZDoom (and related projects) Frontend

Thu Apr 09, 2015 4:05 pm

Bloodbat wrote:
Devianteist wrote:I'll be sure to try out the beta. Yes it worked before, and I am using Windows 7 on both computers that this problem has arisen on. It's baffling as to what may have happened, too, cause it was working fine earlier the day I posted something about it here.

EDIT: Problem solved. Still confused as to what happened, but at least it's working again. :shrug:


Well, it is odd, indeed, but I'm glad it's working again :)


Indeed. Come to realize, a lot of stuff seems to have stopped working! I think my USB might have corrupted some files! Oh dear me.

Re: ZDoom Executor new ZDoom (and related projects) Frontend

Fri Apr 10, 2015 4:19 am

Double posting cause something ain't right;

I've come to notice with the Beta build, some .WADs and .PK3s don't seem to be loading. Granted, it is a Beta build, so stuff broked, but I figured it was worth mentioning. I downloaded it 4 separate times to make sure nothing had corrupted it, and was able to repeat the problem all 4 times.


.PK3s/.WADs were broken.
Last edited by Devianteist on Sat Apr 11, 2015 12:03 pm, edited 1 time in total.

Re: ZDoom Executor new ZDoom (and related projects) Frontend

Fri Apr 10, 2015 11:40 pm

That's curious. I'm using the latest Beta and so far have not encountered this problem.

If you are willing to advise what engine (and version) you use and the names of one or two of the wads. and pk3 that will not load for you, I'd be happy to test them on my PC to see if they load and work properly on my PC or if I have the same problem you are getting Devianteist.

Re: ZDoom Executor new ZDoom (and related projects) Frontend

Sat Apr 11, 2015 12:02 pm

srd333 wrote:That's curious. I'm using the latest Beta and so far have not encountered this problem.

If you are willing to advise what engine (and version) you use and the names of one or two of the wads. and pk3 that will not load for you, I'd be happy to test them on my PC to see if they load and work properly on my PC or if I have the same problem you are getting Devianteist.


The .pk3s in question (honestly I forgot that I posted here) were actually broken I came to find out. So, crap?

Re: ZDoom Executor new ZDoom (and related projects) Frontend

Mon Apr 27, 2015 7:04 pm

With the latest version I'm having trouble with multiplayer options. Whatever option I tick I can not input any information for IP Address whatsoever.

Re: ZDoom Executor new ZDoom (and related projects) Frontend

Tue Apr 28, 2015 4:20 am

Lava Grunt wrote:With the latest version I'm having trouble with multiplayer options. Whatever option I tick I can not input any information for IP Address whatsoever.


Same problem I've been having with the non-beta build. It just up and quit working.

Re: ZDoom Executor new ZDoom (and related projects) Frontend

Wed Apr 29, 2015 11:55 pm

Lava Grunt wrote:With the latest version I'm having trouble with multiplayer options. Whatever option I tick I can not input any information for IP Address whatsoever.


Try the beta build in the mean time, please.

Re: ZDoom Executor new ZDoom (and related projects) Frontend

Thu Apr 30, 2015 11:07 am

Bloodbat wrote:
Lava Grunt wrote:With the latest version I'm having trouble with multiplayer options. Whatever option I tick I can not input any information for IP Address whatsoever.


Try the beta build in the mean time, please.

So far it seems to be great! I like how you don't have to specify the paths to individual IWADs and PWADs now (instead just their residing folders) and the other options, plus I can input into the IP Address field now. Solid stuff man.

EDIT: Oh, and also thanks for changing the way a selected file scrolls now in external files. Forgot to mention it's old behavior before of how it would stay select-locked on a position in the list rather than the file you clicked.

EDIT EDIT: Seems to be wonky atm, but I can't tell for sure since there seems to be some profile settings saved in what I presume is AppData, but I can't find them. Anyway, trying to use the beta to play HD with the sprite fix project leads to some wonky results, in what I'm guessing is some IWAD loading error.

EDIT 3: After finding ZDE's config in my user folder (which holds my AppData folder), I deleted and started ZDE beta from scratch. Same error.

Re: ZDoom Executor new ZDoom (and related projects) Frontend

Sun May 03, 2015 11:41 pm

Lava Grunt wrote:EDIT EDIT: Seems to be wonky atm, but I can't tell for sure since there seems to be some profile settings saved in what I presume is AppData, but I can't find them. Anyway, trying to use the beta to play HD with the sprite fix project leads to some wonky results, in what I'm guessing is some IWAD loading error.

EDIT 3: After finding ZDE's config in my user folder (which holds my AppData folder), I deleted and started ZDE beta from scratch. Same error.


I'm not aware of such project...but wonky how? Your profiles are saved wherever you chose to save them to, the program doesn't touch %appdata% by itself ever. The configuration file (that has no relation to whatever options you set in a profile, other than pointing profiles to the game type and engine) is located in %homepath% unless you turned the app into a "portable" app. Check here: https://sourceforge.net/p/zdexe/wiki/Portable%20App/, the beta saves a profile (if told to via Options -> Save Last Profile on Exit) in the same folder named .last.zdeprof and loads it on start (again it accounts for the app being turned "portable"), but that's it. Check ZDoom's console for errors, as the mysterious wonkiness is probably related to a messed up load order or an error in the sprite fix project, this beta fixes a "bug" where external files were being loaded in reverse of what ZDoom expects, i.e the top external file was loaded by ZDoom last, if it used to work right before and now it doesn't...invert the order of the external files (say you are using 3, send the first to last and the last to first).

Re: ZDoom Executor new ZDoom (and related projects) Frontend

Mon May 04, 2015 1:34 am

I didn't say it's in my AppData folder, but my user folder. I just usually expect to find configs in AppData if I can't already in the program's folder. I'll try again, but the only thing I was doing was loading scythe 2, then sprite fix, then HD, and it botched something pretty bad that's akin to problems with running HD in Doom 1/Ultimate Doom without loading Doom 2 as a pwad. i.e. shit was wonky. Went back to the second recent version and it worked with no issues. Checking the GZDoom console to see if ZDE had for some reason loaded Ultimate Doom as a PWAD for my Doom 2 game proved to not be the case, so the only thing I can guess is something is borked in the beta.

EDIT: Chose to save them to? I didn't know there was an option for that.

Re: ZDoom Executor new ZDoom (and related projects) Frontend

Mon May 04, 2015 10:30 am

Lava Grunt wrote:I didn't say it's in my AppData folder, but my user folder. I just usually expect to find configs in AppData if I can't already in the program's folder. I'll try again, but the only thing I was doing was loading scythe 2, then sprite fix, then HD, and it botched something pretty bad that's akin to problems with running HD in Doom 1/Ultimate Doom without loading Doom 2 as a pwad. i.e. shit was wonky. Went back to the second recent version and it worked with no issues. Checking the GZDoom console to see if ZDE had for some reason loaded Ultimate Doom as a PWAD for my Doom 2 game proved to not be the case, so the only thing I can guess is something is borked in the beta.

EDIT: Chose to save them to? I didn't know there was an option for that.


Whenever you save a profile a dialog pops up that lets you set filename and location.
The only change related to loading external stuff is the order...as I said, it was sending stuff in reverse of what ZDoom expects, from ZDoom's wiki:
"file file1[.wad] file2[.wad] file3[.wad] ...
Used to load one or more PWAD files which generally contain user-created levels. Files listed further right take precedence to files listed before them [...]"
So, that was corrected (it was working in reverse), try altering the order of the PWADs.

Edit: I ask again, wonky how? What was the expected result and what did you get instead...so I can test it myself.

Re: ZDoom Executor new ZDoom (and related projects) Frontend

Mon May 04, 2015 10:49 am

D'oh...while I'm against the way ZDoom reads externals (seriously, what you chronologically input is what should be chronologically loaded), I commend you on making it consistent.

Re: ZDoom Executor new ZDoom (and related projects) Frontend

Mon May 04, 2015 11:02 am

Lava Grunt wrote:D'oh...while I'm against the way ZDoom reads externals (seriously, what you chronologically input is what should be chronologically loaded), I commend you on making it consistent.


Thank you, I disagree with it as well, but...what can we do? :P

Re: ZDoom Executor new ZDoom (and related projects) Frontend

Sat May 09, 2015 7:46 am

Nice frontend you got here Bloodbat. Definitely the least cumbersome from all I tried so far. :)
I am using latest beta build of it (from 6th May) and I found little incovience. Even if you have ticked "Save slot when exiting", it will not save it if launcher got closed when launching zdoom (if you have enabled "exit when launching"). Could this be fixed up? Thanks.