Re: Winter's Fury

Fri Jul 14, 2017 6:39 pm

Oniria wrote:all I can hear is some wind sounds and it shuts off with a fatal error message.


Unless you are talking about a generic fatal error message from windows, you could copy-paste the message.

I just tried it on GZDoom 3.1 and had no problems.

Re: Winter's Fury

Fri Jul 14, 2017 7:06 pm

No, this shows up every time I try to load the wad, while I can hear the sound still playing in the background (as aforementioned the wind sounds).

Spoiler:


Here's the log, altho I don't see any particular error messages in the log as to why and how..

OS: Windows 7 (NT 6.1) Build 7601
Service Pack 1
M_LoadDefaults: Load system defaults.
Using program directory for storage
W_Init: Init WADfiles.
adding G:/Games/DooM (Incl. Skulltag & Zandronum)/Zandronum/Wads/Winter's Fury v2016.5/gzdoom.pk3, 713 lumps
adding doom2.wad, 2919 lumps
adding lights.pk3, 6 lumps
adding brightmaps.pk3, 500 lumps
adding G:/Games/DooM (Incl. Skulltag & Zandronum)/Zandronum/Wads/Winter's Fury v2016.5/Winter's Fury.wad, 5250 lumps
I_Init: Setting up machine state.
CPU speed: 2295 MHz
CPU Vendor ID: GenuineIntel
Name: Intel(R) Core(TM) i3-2350M CPU @ 2.30GHz
Family 6, Model 42, Stepping 7
Features: SSE2 SSE3 SSSE3 SSE4.1 SSE4.2
I_InitSound: Initializing OpenAL
Opened device OpenAL Soft on Speakers (Realtek High Definition Audio)
EFX enabled
Renderer: OpenGL
V_Init: allocate screen.
S_Init: Setting up sound.
ST_Init: Init startup screen.
Checking cmd-line parameters...
S_InitData: Load sound definitions.
G_ParseMapInfo: Load map definitions.
Texman.Init: Init texture manager.
ParseTeamInfo: Load team definitions.
LoadActors: Load actor definitions.
script parsing took 360.59 ms
R_Init: Init Doom refresh subsystem.
DecalLibrary: Load decals.
M_Init: Init menus.
P_Init: Init Playloop state.
ParseSBarInfo: Loading custom status bar definition.
"Don't look at me like that."
"I used to be a lot like you, you know."
"Left without a chance to accomplish the impossible."
"No chance to accomplish my dreams."
"But I will fix that. I will fix everything"
D_CheckNetGame: Checking network game status.
player 1 of 1 (1 nodes)
I_InitInput
I_StartupMouse
I_StartupKeyboard
I_StartupXInput
I_StartupRawPS2
I_StartupDirectInputJoystick
GL_VENDOR: Intel
GL_RENDERER: Intel(R) HD Graphics 3000
GL_VERSION: 3.1.0 - Build 8.15.10.2696 (Compatibility profile)
GL_SHADING_LANGUAGE_VERSION: 1.40 - Intel Build 8.15.10.2696

Max. texture size: 8192
Max. texture units: 16
Max. varying: 41
Max. uniform block size: 16384
Uniform block alignment: 16
Resolution: 1366 x 768

═════════════════════════════════

titlemap - Winter's Fury


guineu wrote:I just tried it on GZDoom 3.1 and had no problems.


Makes it only stranger as to why it doesn't on my end.

Re: Winter's Fury

Fri Jul 14, 2017 8:14 pm

If I had to guess I'd say it's something related to your integrated graphics card. Maybe try changing some of the display options in GZDoom before loading this mod.

Hope someone else can give you a more precise answer.

Re: Winter's Fury

Fri Jul 14, 2017 8:26 pm

Oniria wrote:Makes it only stranger as to why it doesn't on my end.


I've tested it with the exact version of GZDoom you were using in your error picture, and it works perfectly fine for me.

I think the problem may be to do with your system specifications. Somebody correct me if I'm wrong, but I think that the later versions of GZDoom need to use a certain version of Open GL, which some graphics drivers cannot handle. This could be the case for you. If you could post your specifications here, that could be helpful.

Also, try running another high end GZDoom mod, like Blade of Agony. If it doesn't work either, it's likely due to your system.

Re: Winter's Fury

Fri Jul 14, 2017 10:29 pm

guineu wrote:If I had to guess I'd say it's something related to your integrated graphics card. Maybe try changing some of the display options in GZDoom before loading this mod.

Hope someone else can give you a more precise answer.

Well yes, I tried that aswell while loading up regular doom2 and fiddling around with the options, nothing seems to help..

Pyroscourge wrote:I've tested it with the exact version of GZDoom you were using in your error picture, and it works perfectly fine for me.

I think the problem may be to do with your system specifications. Somebody correct me if I'm wrong, but I think that the later versions of GZDoom need to use a certain version of Open GL, which some graphics drivers cannot handle. This could be the case for you. If you could post your specifications here, that could be helpful.

Also, try running another high end GZDoom mod, like Blade of Agony. If it doesn't work either, it's likely due to your system.



Hello there, well here are my specifications.

A laptop with the following specs:

Windows 7 64bit
Intel Core i3-2350M CPU @ 2.30 Ghz, 4 GB RAM, Intel HD Graphics 3000

As for other mods, well I Haven't tried Blade of Agony yet (its not rly my cup of tea) but.. i DO have another example.

I tried loadin up Brutal doom once with the latest gzdoom and while it loaded up fine (in other words i got ingame), upon firing a single shot with a weapon however I got a Gzdoom very fatal error.
But upon loading the mod with Zandronum it works fine there without booting out or anything like it did with gzdoom.

If it was a pc problem tho, the mod ( still talkin of ButalDoom) shouldve not been able to run on the other port aswell, but it does. Except not on Gzdoom. The reason I use this example is the way it gave the fatal error was almost in the same vein as your mod wich I've been hopelessly trying to play without much succes thus far.

Winters Fury however doesnt appear to load at all it seems ,in other words not even getting ingame, it alrdy gives the fatal error beforehand.

At this point Im really clueless, but there seems to be something fishy with either this Gzdoom, or indeed be something related to my hardware?

But since Im totally no professional in this field I cannot possibly know for certain, unless theres someone with professional knowledge who can.

Other then that, I've been dying to play your mod all this time but saddened off by these affairs :oops: Plz Halp. Am I a hopeless case? Will I never be able to enjoy your mod? :cry:

Re: Winter's Fury

Sat Jul 15, 2017 12:26 am

You're probably running it with bad video drivers. Try running it with "-glversion 2" on the command line. If that fixes it, you need to update your drivers.

Re: Winter's Fury

Sat Jul 15, 2017 1:39 am

Intel HD3000 and the modern render path have been found not to mix well, so yes, this looks like a likely culprit for the problems.

Re: Winter's Fury

Sat Jul 15, 2017 2:53 pm

Rachael wrote:You're probably running it with bad video drivers. Try running it with "-glversion 2" on the command line. If that fixes it, you need to update your drivers.

Do you know where to put this command? I've tried the console command but it wasn't recognizing the command, then I' searched for it in my gzdoom doc. where I couldn't find it so I put it right under Global settings like this, wich didn't work (perhaps it didn't recognize it like that there).

Image

I've tried to update drivers aswell but there seems to be no updates for it..

Graf Zahl wrote:Intel HD3000 and the modern render path have been found not to mix well, so yes, this looks like a likely culprit for the problems.


Intel (R) HD Graphics 3000 according to my system settings indeed.

And upon installing the driver update utility from their site I get this message.

Image

It was...heartbreaking.. :cry:

Re: Winter's Fury

Sat Jul 15, 2017 3:01 pm

Type it into your folder's location bar: (having your GZDoom folder open, of course) - afterwards, hit enter.
explorertitlebar.png
You do not have the required permissions to view the files attached to this post.

Re: Winter's Fury

Sat Jul 15, 2017 3:31 pm

Rachael wrote:Type it into your folder's location bar: (having your GZDoom folder open, of course) - afterwards, hit enter.
explorertitlebar.png


When I try putting that in the location bar (while having the folder open) it tells me "location not found error" upon hitting enter.

Image

Re: Winter's Fury

Sat Jul 15, 2017 5:59 pm

Oniria wrote:When I try putting that in the location bar (while having the folder open) it tells me "location not found error" upon hitting enter.


Delete everything else (G:\Games\etc...) and type only this:
example.jpg
You do not have the required permissions to view the files attached to this post.

Re: Winter's Fury

Sat Jul 15, 2017 6:27 pm

You would have to type that line every time you want to play Winter's Fury.
An easier way is to use a batch file and just drag Winter's Fury onto it, eg play.bat

Code:
gzdoom.exe -iwad DOOM2 -file %1 -glversion 2 +logfile startup.txt

Re: Winter's Fury

Sat Jul 15, 2017 6:41 pm

guineu wrote:
Oniria wrote:When I try putting that in the location bar (while having the folder open) it tells me "location not found error" upon hitting enter.


Delete everything else (G:\Games\etc...) and type only this:
example.jpg


Oh shit.. it seems that works.

And it does load up without crashing. :shock:

Well I guess I will save that command in my notepad to be used with this mod once Im ready to play it (still going through a list of other megawads wich I want to finish).

It turned out to be indeed a driver issue, wich, to make matters worse cant even be updated in order to resolve the issue. However despite that I'm still able to load up the mod using this command so it works for me that way. I can live with that, atleast I can play the mod now wich is all I rly wanted.

Even though the latest Gzdoom's opengl still works for me on this hardware with regular wads, i know now aswell that my drivers arent optimal (anymore).
This also explains some similar problems I had with the Gzdoom-only wad Shadow of the Nightmare realm.

Let me just thank you all for sincerely helping me out in this, pinpointing the problem and making things clear, Rachael and Graf Zaal. :3:

Re: Winter's Fury

Wed Oct 11, 2017 1:07 pm

This probably may have been asked to death, but can this map run with gameplay mods? (i.e. GMOTA, D4T, Brutal Doom etc)

Re: Winter's Fury

Wed Oct 11, 2017 8:31 pm

If you know how to mod, sure.