[4.7.0] crash to desktop when loading shader + cameratexture

Fri Oct 15, 2021 5:33 pm

Happens in 4.7.0 and g4.8pre-28-gbc75dc056 (both 32-bit)

Windows 10, some old but not totally ancient integrated Intel thing.

Works fine in OpenGL.

To replicate:

Load some recent build of Hideous Destructor:
https://codeberg.org/mc776/hideousdestr ... d659bb29e8

Start a game.

Type "give HDBlurSphere" in the console.

Attempt to use said blursphere.


Expected: your view should turn into this washed-out desaturated pixelated mess.
Actual: crash to desktop. Crash report attached. Updated crash report below.


The point in HD where the camera texture is loaded: https://codeberg.org/mc776/hideousdestr ... re.zs#L306
The shader: https://codeberg.org/mc776/hideousdestr ... aturate.fp
Last edited by Matt on Tue Nov 30, 2021 1:16 am, edited 2 times in total.

Re: [4.7.0] crash to desktop when loading shader + cameratex

Sun Nov 21, 2021 6:03 am

Thanks, should be fixed here:
https://github.com/coelckers/gzdoom/pull/1511

It will just load the default shader in this case so the image will not be as designed but it won't crash out at least.

Re: [4.7.0] crash to desktop when loading shader + cameratex

Tue Nov 30, 2021 1:15 am

Just tried latest devbuild (gzdoom-x64-g4.8pre-77-g01b825b18), still crashes.

EDIT: deleted attached crash log pending trying this again...
Last edited by Matt on Tue Nov 30, 2021 10:12 pm, edited 1 time in total.

Re: [4.7.0] crash to desktop when loading shader + cameratex

Tue Nov 30, 2021 3:05 am

Currently devbuilds are down, the last one is from 14th and it was fixed later.