Weird (Renderer?) Visual Glitch

Mon Jun 10, 2019 8:31 pm

I just encountered a weird visual glitch. Looking at an area at a certain angle shows everything as it ought to be. Lowering the field of view fractionally really messes up the view. Lowering the field of view again resolves the issue. So it's only when the view falls within a narrow angular range. This problem does not seem to happen from every possible viewpoint, but I haven't tried changing position too much.

GZDoom v3.7.2 Legacy; hardware acceleration (not an external video card)

Here is a normal view of the scene:
ZD_Normal.jpg


Here is the messed up view of the scene:
ZD_Messy.jpg
You do not have the required permissions to view the files attached to this post.

Re: Weird (Renderer?) Visual Glitch

Mon Jun 10, 2019 10:09 pm

First and most obvious question is going to be - what is your GPU?

We should also know your operating system and what kind of CPU you have.

Re: Weird (Renderer?) Visual Glitch

Tue Jun 11, 2019 12:40 am

Also important:

What map?
What does the modern build do?

Re: Weird (Renderer?) Visual Glitch

Tue Jun 11, 2019 5:19 am

@Rachael: I can’t check right now but will send info as soon as I can.

@Graf: 1. It’s a custom map (WIP), which I can send you if needed
2. I haven’t used the newest build, but I’ll download, try out, and report back

Re: Weird (Renderer?) Visual Glitch

Wed Jul 17, 2019 12:11 pm

I'll still need the map to analyze the problem.

Re: Weird (Renderer?) Visual Glitch

Wed Jul 17, 2019 5:11 pm

Rex seems to do a lot of hit and run forum visits. He'll be here for a few days and then he'll disappear for a couple months. I'm hoping that he won't forget about this, though.

I'm just letting you know, in hoping to make it less likely you'll close this.

Re: Weird (Renderer?) Visual Glitch

Wed Aug 07, 2019 11:27 am

Still no response. :(
But seeing that this is the vintage build and ReX having said he's still using old hardware, I am now moving this to the proper subforum.