[3.6] Crash with mods

Sat Oct 13, 2018 4:11 am

GZDoom vintage 3.6 crashes when trying to open a level or difficulity with mod installed. No matter when it's Doom Tournament or my own mod.
You do not have the required permissions to view the files attached to this post.

Re: [3.6] Crash with mods

Sat Oct 13, 2018 4:15 am

The crash occurs inside the graphics driver. What happens if you use older GZDoom versions?

Re: [3.6] Crash with mods

Sat Oct 13, 2018 6:07 am

What happens with 3.5 and 3.4 versions? 3.3.2 should not crash.

You could try LZDoom (it's the older legacy build with the old renderer) too.
https://github.com/drfrag666/gzdoom/releases/download/3.51b1/LZDoom_3.51b1.zip

Re: [3.6] Crash with mods

Sat Oct 13, 2018 8:16 am

Quick info: I'm using wtfi.exe

Re: [3.6] Crash with mods

Sat Oct 13, 2018 10:52 am

wtfi.exe doesn't really do anything to the executable itself except add some forced compatibility settings in order to get Intel's OpenGL ICD working.

Re: [3.6] Crash with mods

Sat Oct 13, 2018 12:16 pm

Rachael wrote:wtfi.exe doesn't really do anything to the executable itself except add some forced compatibility settings in order to get Intel's OpenGL ICD working.

AFAIK it simply removes the Win 10 support from the manifest - this makes GZDoom (and, by extension, the OpenGL driver) think it's running on Windows 8(.1).

@OP does your mod have models too? If so, it could be crashing because of the models.
On my old Intel GPU, models would crash the game when displayed, so maybe this could be the what's causing your crash.

Re: [3.6] Crash with mods

Sat Oct 13, 2018 4:15 pm

Do sectors models count? Doom Tournament has, and GZDoom crashes not only on this mod, even crashes on a normal map created by me