Re: LZDoom 3.84 released

Mon Dec 16, 2019 11:06 am

Graf Zahl wrote:1) The last 4.1 release


4.1.3 exactly^^

Re: LZDoom 3.84 released

Thu Dec 19, 2019 12:34 pm

The download link still points to the old version, which is clearly evident just looking at the download numbers.

Re: LZDoom 3.84 released

Thu Dec 19, 2019 12:41 pm

Which link? In the download page?

Re: LZDoom 3.84 released

Thu Dec 19, 2019 1:04 pm

Yes, it still points to 3.83a.

Re: LZDoom 3.84 released

Fri Dec 20, 2019 8:21 am

The link on the main forum page says and leads to 3.83a, too:

Errors? Can't run that new mod? Your GZDoom or ZDoom may be too old!
If you get startup errors - always double check to make sure you're running the latest version! (Currently: 4.2.4/3.83a)

Re: LZDoom 3.84 released

Fri Dec 20, 2019 8:41 am

I'm still mostly offline but like the old and obsolete terminator i say i'll be back.

Re: LZDoom 3.84 released

Fri Dec 20, 2019 10:36 am

m8f wrote:The link on the main forum page says and leads to 3.83a, too:

Errors? Can't run that new mod? Your GZDoom or ZDoom may be too old!
If you get startup errors - always double check to make sure you're running the latest version! (Currently: 4.2.4/3.83a)

Oh, whoops, that's my thing.

Fixed.

Re: LZDoom 3.84 released

Sat Dec 21, 2019 6:03 am

I've managed to update the download page but it's not nice without an internet connection at home.

Re: LZDoom 3.84 released

Mon Dec 30, 2019 10:15 am

Is this LZDoom version supposed to work on GNU/Linux with SDL2 using GLES2 instead of desktop OpenGL?

I tried it after setting renderer to 1 on the ini file, and I got a fast-repeating error about OpenGL functions not being loaded. But maybe I should try other settings?

Re: LZDoom 3.84 released

Mon Dec 30, 2019 10:27 am

No, it cannot target GLES2.
AFAIK GLES 3.1 is possible but "Legacy" here means real OpenGL 2.0.

Re: LZDoom 3.84 released

Tue Dec 31, 2019 2:33 am

Graf Zahl wrote:No, it cannot target GLES2.
AFAIK GLES 3.1 is possible but "Legacy" here means real OpenGL 2.0.


Hmm... But I dont get it. By using a software renderer, the engine itself does not depend on OpenGL. Then, let SDL2 scale using whatever SDL2 renderer it runs on, be it OpenGL or GLES2.

Re: LZDoom 3.84 released

Tue Dec 31, 2019 2:42 am

The backend in 4.2.x requires OpenGL 3.3. This will change with the next release.

Re: LZDoom 3.84 released

Tue Dec 31, 2019 10:48 am

Graf Zahl wrote:The backend in 4.2.x requires OpenGL 3.3. This will change with the next release.


Do you mean "vanilla" GZDoom 4.2.x? Will it support GLES2 again with the software renderer? :3:

Re: LZDoom 3.84 released

Tue Dec 31, 2019 2:22 pm

Yes.

Re: LZDoom 3.84 released

Mon Jan 13, 2020 3:57 pm

Rachael wrote:Yes.


Whoa!!! I will be waiting for this :)