Brutal Doom/Ketchup "Expected ',', got 'l'." [split split]

Need help running G/Q/ZDoom/ECWolf/Zandronum/3DGE/EDuke32/Raze? Did your computer break? Ask here.

Moderator: GZDoom Developers

Forum rules
Contrary to popular belief, we are not all-knowing-all-seeing magical beings!

If you want help you're going to have to provide lots of info. Like what is your hardware, what is your operating system, what version of GZDoom/LZDoom/whatever you're using, what mods you're loading, how you're loading it, what you've already tried for fixing the problem, and anything else that is even remotely relevant to the problem.

We can't magically figure out what it is if you're going to be vague, and if we feel like you're just wasting our time with guessing games we will act like that's what you're really doing and won't help you.
User avatar
Niphura
Posts: 192
Joined: Fri Jun 16, 2017 3:07 pm
Location: Argentina

Brutal Doom/Ketchup "Expected ',', got 'l'." [split split]

Post by Niphura »

I´ve got GZdoom 3.0 and i want to run Ketchup v5 blood pack but when i run the game this appears: Image
User avatar
wildweasel
Moderator Team Lead
Posts: 21510
Joined: Tue Jul 15, 2003 7:33 pm
Preferred Pronouns: He/Him
Operating System Version (Optional): Windows 10, 21H1
Graphics Processor: nVidia with Vulkan support

Re: OpenGL: Glitchy scene [split]

Post by wildweasel »

That's a very, VERY well known error with Brutal Doom and its derivatives. The problem is in decorate.blood.txt, where a rogue typo declares an A_FadeOut with an argument of 0.l instead of 0.1. That's a lowercase letter L. Older ZDoom didn't care about this typo. Newer GZDooms crash on it because the parser got tuned up significantly.

[edit] I split the error and my response - partially because it's off-topic to your other Tech Issues thread, but also so I can redirect people to this post whenever the error gets brought up. Because it's been a problem for more than half a year and it's still cropping up, and people are still asking about it.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
Posts: 48358
Joined: Sat Jul 19, 2003 10:19 am
Location: Germany

Re: Brutal Doom/Ketchup "Expected ',', got 'l'." [split spli

Post by Graf Zahl »

And let's note that the real problem here is that even after this error was reported to the BD creator very early after its discovery, he did - nothing - and let the error sit for countless derivatives to copy it. I'm a bit puzzled that even after 1.5 years there' still mods floating around that do not have this fixed. :(
User avatar
drfrag
Vintage GZDoom Developer
Posts: 3111
Joined: Fri Apr 23, 2004 3:51 am
Location: Spain

Re: Brutal Doom/Ketchup "Expected ',', got 'l'." [split spli

Post by drfrag »

True, BD v21 is supposed to come out soon but who knows.
In the meantime you can use any of the available addons that fix the problem, i recommend mine since it fixes other problems too and well becouse it's mine.

http://www.moddb.com/mods/brutal-doom/a ... cial-patch
User avatar
Niphura
Posts: 192
Joined: Fri Jun 16, 2017 3:07 pm
Location: Argentina

Re: OpenGL: Glitchy scene [split]

Post by Niphura »

wildweasel wrote:That's a very, VERY well known error with Brutal Doom and its derivatives. The problem is in decorate.blood.txt, where a rogue typo declares an A_FadeOut with an argument of 0.l instead of 0.1. That's a lowercase letter L. Older ZDoom didn't care about this typo. Newer GZDooms crash on it because the parser got tuned up significantly.

[edit] I split the error and my response - partially because it's off-topic to your other Tech Issues thread, but also so I can redirect people to this post whenever the error gets brought up. Because it's been a problem for more than half a year and it's still cropping up, and people are still asking about it.
Thank you very much! i edit the A_FadeOut parts of the decorate.blood.txt and it works fine now! :)
Guest

Re: Brutal Doom/Ketchup "Expected ',', got 'l'." [split spli

Post by Guest »

Hey, can I ask a small question?

what did you do to edit the part of the "a_fadeout" bit?
also have the same problem as you.
twoplugs

Re: Brutal Doom/Ketchup "Expected ',', got 'l'." [split spli

Post by twoplugs »

Guest wrote:
> Hey, can I ask a small question?
>
> what did you do to edit the part of the "a_fadeout" bit?
> also have the same problem as you.

Guest wrote:
> Hey, can I ask a small question?
>
> what did you do to edit the part of the "a_fadeout" bit?
> also have the same problem as you.

Sorry for very delayed reply, only just came across this problem (and thread) myself. If you've already fixed it, I hope that at least this will help others with the same problem.

Here's what to do:
1) Open the ketchup .pk3 file. You can do this with WinRAR. I think ketchupV5.pk3 and ketchupV5_nogibs_splattersonly.pk3 are the pk3s of the most recent version.
2) Open decorate.blood.txt in Notepad.
3) Ctrl+F search for FadeOut(0.l) where 'l' is a lowercase 'L'
4) Change the lowercase 'L' to the number '1'
5) Save
6) Confirm you want to update the archive.
7) Run ketchup as normal

Hope that helps

Return to “Technical Issues”