[Fixed] Minotaur ground attack

Bugs that have been investigated and resolved somehow.

Moderator: GZDoom Developers

Forum rules
Please don't bump threads here if you have a problem - it will often be forgotten about if you do. Instead, make a new thread here.
User avatar
LilWhiteMouse
Posts: 2270
Joined: Tue Jul 15, 2003 7:00 pm
Location: Maine, US

Minotaur ground attack

Post by LilWhiteMouse »

One of the minotaur attacks doesn't work right anymore, the ground hugging attack.

Image

The two bright blue things are the projectiles. They're not quite sitting still, just moving very slowly. This is with 57.
User avatar
Enjay
 
 
Posts: 26536
Joined: Tue Jul 15, 2003 4:58 pm
Location: Scotland

Post by Enjay »

Strange - I just checked Heretic E2M8 and the Minotaurs were working fine. I haven't tried bringing a Minotaur into a Doom game though.
User avatar
LilWhiteMouse
Posts: 2270
Joined: Tue Jul 15, 2003 7:00 pm
Location: Maine, US

Post by LilWhiteMouse »

I summoned one in Hexen and his first couple shots were fine. After the third of fourth though, they started doing this nonsense again.
User avatar
Enjay
 
 
Posts: 26536
Joined: Tue Jul 15, 2003 4:58 pm
Location: Scotland

Post by Enjay »

Very strange. I'm just not getting it. Tried in Hexen. I let a minotaur run around for maybe 6-7 minutes and still all the attacks were fine. I'm using 2.0.57 too.

Edit: OK, yes, I got the effect in Doom. As you said, the attacks are still moving, just very slowly. So they are not being blocked by something physical, or a blocking line of some sort. They are just crawling along the floor for no obvious reason.
User avatar
randi
Site Admin
Posts: 7746
Joined: Wed Jul 09, 2003 10:30 pm

Post by randi »

I think I found the problem: The missile spawning function spawned floor/ceiling huggers as if they could move with a vertical component to their velocity. They can't, so it could result in very slow moving projectiles when aiming at something nearby in the X/Y plane but far away on the Z axis, because most of the projectile's speed would try to go on the Z axis.

Return to “Closed Bugs [GZDoom]”