A way to disable lighting on a weapon model?

Ask about editing graphics, sounds, models, music, etc here!
Shaders (GLSL) and SNDINFO questions also go here!

Moderators: GZDoom Developers, Raze Developers

Forum rules
Before asking on how to use a ZDoom feature, read the ZDoom wiki first. If you still don't understand how to use a feature, then ask here.
User avatar
SPZ1
Posts: 309
Joined: Wed Aug 02, 2017 3:01 pm
Location: Illinois

A way to disable lighting on a weapon model?

Post by SPZ1 »

You can see that when this weapon is brought into a light, the arm portion of it looks like crap.

User avatar
Enjay
 
 
Posts: 26537
Joined: Tue Jul 15, 2003 4:58 pm
Location: Scotland

Re: A way to disable lighting on a weapon model?

Post by Enjay »

That *could* be a problem with the model itself. Have you checked the normals for the model?
User avatar
SPZ1
Posts: 309
Joined: Wed Aug 02, 2017 3:01 pm
Location: Illinois

Re: A way to disable lighting on a weapon model?

Post by SPZ1 »

It is definitely a problem with the model. I thought that turning off lighting would be the solution. I didn't make the model myself and I haven't had it in Blender but if there is another solution I'll post it.
User avatar
SPZ1
Posts: 309
Joined: Wed Aug 02, 2017 3:01 pm
Location: Illinois

Re: A way to disable lighting on a weapon model?

Post by SPZ1 »

I found that the 'Recalculate Outside' feature in Blender completely solved the problem.

Return to “Assets (and other stuff)”