Vulkan renderer has microstutters

Need help running G/Q/ZDoom/ECWolf/Zandronum/3DGE/EDuke32/Raze? Did your computer break? Ask here.

Moderator: GZDoom Developers

Forum rules
Contrary to popular belief, we are not all-knowing-all-seeing magical beings!

If you want help you're going to have to provide lots of info. Like what is your hardware, what is your operating system, what version of GZDoom/LZDoom/whatever you're using, what mods you're loading, how you're loading it, what you've already tried for fixing the problem, and anything else that is even remotely relevant to the problem.

We can't magically figure out what it is if you're going to be vague, and if we feel like you're just wasting our time with guessing games we will act like that's what you're really doing and won't help you.
User avatar
Blackgrowl
Posts: 88
Joined: Sun Oct 06, 2019 8:47 am
Graphics Processor: nVidia with Vulkan support

Vulkan renderer has microstutters

Post by Blackgrowl »

I want to start by saying that this is not even just GZDoom, but also RAZE and perhaps even every game that uses Vulkan as a whole. Might go as far as to include the wrapper DXVK, but I have not tested thoroughly.
I've had a conversation in another thread about Vulkan where I had issues with how the game felt not smooth at all here; viewtopic.php?p=1235644
Sadly, although I thought the problem was fixed, it was not. And even if I can just use OpenGL, well, I can't give any good argument other than that "what I want to use should function correctly for me and all" as well as that what about Vulkan-only games like Doom Eternal, but that's another game.

I've been using Vulkan (on both GZDoom and RAZE might I add) for a long time and I never had issues until I got a new PC, but an important information for this new PC is that, my videocard is still the same, it's an Nvidia RTX 2070.
And although I was not paying attention, I am very sure I never had stutters even on my new PC, this problem started with most surely an Nvidia driver update. My current driver version is 527.56, I went ahead and reverted to 522 and then to 512.

My reasoning for that inversion is because of what's documented in here: https://uk.download.nvidia.com/Windows/ ... -notes.pdf
In there, you can see that they apparently added OpenCL support for Vulkan in the 525 release. I have a theory that this might be the cause.

I was wrong. I still had stutters, yet thankfully I was not the only one with issues and the subject in question also had the desire to debug such an issue, as seen here: https://www.nvidia.com/en-us/geforce/fo ... picPage=40

So, according to that post, I reverted to 512 and sadly the problem was still there. I have no idea as to why Vulkan would cause stutters, yet OpenGL itself runs fantastically fine.

For better information; my PC is an MPG B550 GAMING PLUS, Ryzen 7 5800X, 32GB of DDR4 at 3200mhz speed, RTX 2070 and GZDoom is in a Crucial SSD.
My monitor is AOC G2260VWQ6, this one has 75hz. In game, I set the framerate max to 72 to avoid possible tearing and VSync used to be on, now it's off (because of the conversation in that GZDoom link, I still have some tears maxed at 75 and anything above 76 causes worse stutters than at 72).

If information is needed on how I test these "microstutters", I play using "Lost Civilization" (https://www.moddb.com/mods/lost-civiliz ... ization-15) and just start from the first area, when I go forward I can see that my grass is very finicky, as if jumping frame-by-frame somehow, it's just so uneven and fuzzy, not smooth at all. With OpenGL though, everything is smooth, the grass looks fantastic.

Because the reversion to driver version 512 didn't work for me, I am unsure if this is an issue with GZDoom or Nvidia itself, so I thought it would be necessary to post this.
User avatar
merlin86
Posts: 134
Joined: Tue Jan 29, 2008 4:02 am
Preferred Pronouns: He/Him
Operating System Version (Optional): Windows 11 Pro
Graphics Processor: nVidia with Vulkan support

Re: Vulkan renderer has microstutters

Post by merlin86 »

Had a similar problem with my 144hz monitor ( AOC ) and Nvidia 3070ti .

Now with : frame limit to 140 ( multiple of 35 ) and Nvidia driver 528.49 the problem is fixed. ( At least for me :) )
User avatar
Blackgrowl
Posts: 88
Joined: Sun Oct 06, 2019 8:47 am
Graphics Processor: nVidia with Vulkan support

Re: Vulkan renderer has microstutters

Post by Blackgrowl »

I've updated to 528.49, tried it out again and surprisingly, even at 75 FPS and higher, I have no stutters whatsoever.

I guess it was yet another Nvidia driver bug that finally got fixed.
User avatar
camaxide
Posts: 382
Joined: Thu Jun 11, 2015 8:38 am

Re: Vulkan renderer has microstutters

Post by camaxide »

I've used GL always, and just recently read that I could improve FPS with Vulkan. I got a very beefy computer running 5GHz all cores and a RTX 4090. I do indeed jump 10-30 % FPS depending on situation/map - however.. Vulkan seem to struggle with stutters here and there, and is super touchy about anything else going on in the background on the computer - where as Gl never once skip a beat. It is bad enough that I would never consider actually playing with Vulkan on.. which is sad seeing how well it runs. I'm at later drivers than you used, and updating now hoping it might be the cause.. I have FPS capped at 200 since I run 160 hz 3840x1600 monitor and want to have it running maxed out.
yum13241
Posts: 781
Joined: Mon May 10, 2021 8:08 pm
Preferred Pronouns: He/Him
Operating System Version (Optional): EndeavorOS (basically Arch)
Graphics Processor: Intel with Vulkan/Metal Support

Re: Vulkan renderer has microstutters

Post by yum13241 »

Try capping your FPS to a multiple of 35.
User avatar
camaxide
Posts: 382
Joined: Thu Jun 11, 2015 8:38 am

Re: Vulkan renderer has microstutters

Post by camaxide »

yum13241 wrote: Sat Apr 22, 2023 12:26 pm Try capping your FPS to a multiple of 35.
The menu options for capping the FPS is: 120, 144 and 200 - does it require manual config editing to run Vulkan smooth? No problem if so, just seem weird if that is the case. 140 FPS would be all right
User avatar
camaxide
Posts: 382
Joined: Thu Jun 11, 2015 8:38 am

Re: Vulkan renderer has microstutters

Post by camaxide »

Updated the drivers and it seem better now - I did have very new drivers to begin with, but seem they mess up vulkan in Doom now and then with the drivers..
Now I mostly have stutter when loading from editor as it boots right into map - but that is likely from gzdoom building lights or something on the go in the start.
yum13241
Posts: 781
Joined: Mon May 10, 2021 8:08 pm
Preferred Pronouns: He/Him
Operating System Version (Optional): EndeavorOS (basically Arch)
Graphics Processor: Intel with Vulkan/Metal Support

Re: Vulkan renderer has microstutters

Post by yum13241 »

camaxide wrote: Mon Apr 24, 2023 4:41 pm
yum13241 wrote: Sat Apr 22, 2023 12:26 pm Try capping your FPS to a multiple of 35.
The menu options for capping the FPS is: 120, 144 and 200 - does it require manual config editing to run Vulkan smooth? No problem if so, just seem weird if that is the case. 140 FPS would be all right
Open the console (with the ~ key) and type vid_maxfps 140, then press ENTER.

EDIT: Fixed snafu in post.
Last edited by yum13241 on Tue Apr 25, 2023 7:40 am, edited 1 time in total.
User avatar
Caligari87
Admin
Posts: 6181
Joined: Thu Feb 26, 2004 3:02 pm
Preferred Pronouns: He/Him

Re: Vulkan renderer has microstutters

Post by Caligari87 »

vid_fps shows the current FPS, setting it to 140 won't do anything.

vid_maxfps is what you actually want, to cap it at some arbitrary value without vsync.

8-)
yum13241
Posts: 781
Joined: Mon May 10, 2021 8:08 pm
Preferred Pronouns: He/Him
Operating System Version (Optional): EndeavorOS (basically Arch)
Graphics Processor: Intel with Vulkan/Metal Support

Re: Vulkan renderer has microstutters

Post by yum13241 »

GAAAAAH! What was I smoking?! (in the figurative sense, I don't do drugs, and you shouldn't too. I can't stop you, but I can say I don't do them :))

8-)
bLUEbYTE
Posts: 160
Joined: Fri Nov 15, 2019 4:28 am
Graphics Processor: Intel with Vulkan/Metal Support
Location: Australia

Re: Vulkan renderer has microstutters

Post by bLUEbYTE »

For the record; I've always had micro-stutters on Vulkan backend too. OpenGL has always been stutter-free. More recently, OpenGLES as it has even better performance. My GPU is an 8th gen Intel iris plus.

Return to “Technical Issues”