Address not mapped to object:

Need help running G/Q/ZDoom/ECWolf/Zandronum/3DGE/EDuke32/Raze? Did your computer break? Ask here.

Moderator: GZDoom Developers

Forum rules
Contrary to popular belief, we are not all-knowing-all-seeing magical beings!

If you want help you're going to have to provide lots of info. Like what is your hardware, what is your operating system, what version of GZDoom/LZDoom/whatever you're using, what mods you're loading, how you're loading it, what you've already tried for fixing the problem, and anything else that is even remotely relevant to the problem.

We can't magically figure out what it is if you're going to be vague, and if we feel like you're just wasting our time with guessing games we will act like that's what you're really doing and won't help you.
Muppi
Posts: 7
Joined: Sun Nov 20, 2022 8:02 am
Preferred Pronouns: He/Him
Operating System Version (Optional): Manjaro 5.15
Graphics Processor: ATI/AMD (Modern GZDoom)

Address not mapped to object:

Post by Muppi »

I am using gzdoom version g4.10pre-55-g6c98fc360-m. When I open gzdoom it gives me the menu to choose my WAD, I chose Ultimate Doom & it crashed with
```
Fatal error
Address not mapped to object (signal 11)
```
I have searched the forums for this but none of the solutions work. Thank you in advance. Also this error is reproducable.
_mental_
 
 
Posts: 3784
Joined: Sun Aug 07, 2011 4:32 am

Re: Address not mapped to object:

Post by _mental_ »

Install GDB, run GZDoom under it, and post output of bt command when a crash happens.
Muppi
Posts: 7
Joined: Sun Nov 20, 2022 8:02 am
Preferred Pronouns: He/Him
Operating System Version (Optional): Manjaro 5.15
Graphics Processor: ATI/AMD (Modern GZDoom)

Re: Address not mapped to object:

Post by Muppi »

Gdb is installed. `bt` gives the output
```
#0 0x00007ffff701d64c in () at /usr/lib/libc.so.6
#1 0x00007ffff6fcd958 in raise () at /usr/lib/libc.so.6
#2 0x00005555557dd017 in ()
#3 0x00007ffff6fcda00 in <signal handler called> () at /usr/lib/libc.so.6
#4 0x00007ffff77ec137 in fluid_hashtable_lookup () at /usr/lib/libzmusic.so.1
#5 0x00007ffff77ed8c4 in fluid_settings_get () at /usr/lib/libzmusic.so.1
#6 0x00007ffff77ee021 in fluid_settings_callback_num () at /usr/lib/libzmusic.so.1
#7 0x00007ffff7803474 in delete_fluid_synth () at /usr/lib/libzmusic.so.1
#8 0x00007ffff7681d12 in FluidSynthMIDIDevice::FluidSynthMIDIDevice(int, std::vector<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >, std::allocator<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > > >&) () at /usr/lib/libzmusic.so.1
#9 0x00007ffff7682068 in CreateFluidSynthMIDIDevice(int, char const*) () at /usr/lib/libzmusic.so.1
#10 0x00007ffff76907f6 in MIDIStreamer::CreateMIDIDevice(EMidiDevice_, int) () at /usr/lib/libzmusic.so.1
#11 0x00007ffff76908cb in MIDIStreamer::Play(bool, int) () at /usr/lib/libzmusic.so.1
#12 0x00007ffff7695bc7 in ZMusic_Start () at /usr/lib/libzmusic.so.1
#13 0x0000555555c64c01 in S_ChangeMusic(char const*, int, bool, bool) ()
#14 0x0000555555a13c56 in D_DoAdvanceDemo() ()
#15 0x0000555555a1ecf7 in TryRunTics() ()
#16 0x0000555555a13f7f in D_DoomLoop() ()
#17 0x0000555555a17ea2 in GameMain() ()
#18 0x00005555557be3c3 in main ()
```

EDIT: Sorry, I am inexperienced with gdb, I work with run more.
Last edited by Muppi on Sun Nov 20, 2022 9:57 am, edited 1 time in total.
_mental_
 
 
Posts: 3784
Joined: Sun Aug 07, 2011 4:32 am

Re: Address not mapped to object:

Post by _mental_ »

What’s the value of fluid_patchset CVAR in your config file? It's in ~/.config/gzdoom directory. Alternatively, you can run GZDoom with -nomusic command line option, and check the value of this CVAR in console.
Muppi
Posts: 7
Joined: Sun Nov 20, 2022 8:02 am
Preferred Pronouns: He/Him
Operating System Version (Optional): Manjaro 5.15
Graphics Processor: ATI/AMD (Modern GZDoom)

Re: Address not mapped to object:

Post by Muppi »

Code: Select all

fluid_patchset=gzdoom
Muppi
Posts: 7
Joined: Sun Nov 20, 2022 8:02 am
Preferred Pronouns: He/Him
Operating System Version (Optional): Manjaro 5.15
Graphics Processor: ATI/AMD (Modern GZDoom)

Re: Address not mapped to object:

Post by Muppi »

Also it works when running with -nomusic.
Last edited by Muppi on Sun Nov 20, 2022 10:32 am, edited 1 time in total.
Muppi
Posts: 7
Joined: Sun Nov 20, 2022 8:02 am
Preferred Pronouns: He/Him
Operating System Version (Optional): Manjaro 5.15
Graphics Processor: ATI/AMD (Modern GZDoom)

Re: Address not mapped to object:

Post by Muppi »

There is also

Code: Select all

Could not find patch set gzdoom.

Could not find patch set /usr/share/sounds/sf2/FluidR3_GS.sf2.

Could not find patch set /usr/share/sounds/sf2/FluidR3_GM.sf2.
which I think may be linked to the issue, because it seems to be an audio one.
Muppi
Posts: 7
Joined: Sun Nov 20, 2022 8:02 am
Preferred Pronouns: He/Him
Operating System Version (Optional): Manjaro 5.15
Graphics Processor: ATI/AMD (Modern GZDoom)

Re: Address not mapped to object:

Post by Muppi »

As I guessed it was a sound issue so I moved my fm_banks & soundfonts dir to ~/.config/gzdoom *It can be anywhere in the SoundfontSearch DIrectories*.
Last edited by Muppi on Sun Nov 20, 2022 8:53 pm, edited 1 time in total.
Muppi
Posts: 7
Joined: Sun Nov 20, 2022 8:02 am
Preferred Pronouns: He/Him
Operating System Version (Optional): Manjaro 5.15
Graphics Processor: ATI/AMD (Modern GZDoom)

Re: Address not mapped to object:

Post by Muppi »

Audio is not working now.
_mental_
 
 
Posts: 3784
Joined: Sun Aug 07, 2011 4:32 am

Re: Address not mapped to object:

Post by _mental_ »

There was a bug in ZMusic that leads to a crash when FluidSynth soundfound isn't found. It's fixed now.
Muppi wrote: Sun Nov 20, 2022 8:52 pm Audio is not working now.
Do you have all dependencies installed? If all sounds and music are missing, OpenAL Soft cannot be loaded or something else is wrong with it. Next time, please post complete GZDoom log.
Muppi
Posts: 7
Joined: Sun Nov 20, 2022 8:02 am
Preferred Pronouns: He/Him
Operating System Version (Optional): Manjaro 5.15
Graphics Processor: ATI/AMD (Modern GZDoom)

Re: Address not mapped to object:

Post by Muppi »

please post complete GZDoom log.
Where is the log located? Yes I have installed all dependencies from https://zdoom.org/wiki/Compile_GZDoom_o ... Arch_Linux. OpenAL seems to be working because I get a msg when I press restart sound. Also pulseaudio is not detecting a playback from gzdoom.
Muppi
Posts: 7
Joined: Sun Nov 20, 2022 8:02 am
Preferred Pronouns: He/Him
Operating System Version (Optional): Manjaro 5.15
Graphics Processor: ATI/AMD (Modern GZDoom)

Re: Address not mapped to object:

Post by Muppi »

Issue is solved play tested this time. The problem is that openAL was not using pulseaudio so I used https://www.reddit.com/r/linuxaudio/com ... gaming_on/.
Last edited by Muppi on Wed Nov 23, 2022 9:06 am, edited 1 time in total.
User avatar
wildweasel
Moderator Team Lead
Posts: 21504
Joined: Tue Jul 15, 2003 7:33 pm
Preferred Pronouns: He/Him
Operating System Version (Optional): Windows 10, 21H1
Graphics Processor: nVidia with Vulkan support

Re: Address not mapped to object:

Post by wildweasel »

Please run gzdoom with this command: gzdoom +logfile ~/gzdoomlog.txt and post the contents of that text file in here. (Ideally, in Code tags, as that's a bit neater.)
User avatar
Chris
Posts: 2867
Joined: Thu Jul 17, 2003 12:07 am
Graphics Processor: ATI/AMD with Vulkan/Metal Support

Re: Address not mapped to object:

Post by Chris »

Muppi wrote: Mon Nov 21, 2022 7:12 am Issue is not solved play tested this time. The problem is that openAL was not using pulseaudio so I used https://www.reddit.com/r/linuxaudio/com ... gaming_on/.
FWIW, the newest versions won't default to JACK anymore when it's server is running, and will prefer PipeWire or PulseAudio when they're available. Though annoyingly, some distros are very behind on OpenAL for whatever reason (Debian unstable is still on 1.19.1, which is several years old, and 1.22.2 has been out for several months already).
Muppi
Posts: 7
Joined: Sun Nov 20, 2022 8:02 am
Preferred Pronouns: He/Him
Operating System Version (Optional): Manjaro 5.15
Graphics Processor: ATI/AMD (Modern GZDoom)

Re: Address not mapped to object:

Post by Muppi »

wildweasel wrote: Mon Nov 21, 2022 8:48 am Please run gzdoom with this command: gzdoom +logfile ~/gzdoomlog.txt and post the contents of that text file in here. (Ideally, in Code tags, as that's a bit neater.)
It works, there was a mistake in my reply.

Return to “Technical Issues”