Intel - iRIS Xe screen flickering, sprites not rendered at all

Moderator: GZDoom Developers

Darkcrafter
Posts: 531
Joined: Sat Sep 23, 2017 8:42 am
Graphics Processor: nVidia with Vulkan support

Intel - iRIS Xe screen flickering, sprites not rendered at all

Post by Darkcrafter »

So I tried to launch modern GZDoom on a laptop with Intel iRIS Xe integrated graphics which is Intel's new quite good AMD VEGA analag. The thing is that newest graphics driver has been installed yet I'm not sure if I have to install Vulkan SDK or something somewhere buried on the web to make GZDoom work flawlessly?

I haven't tried launching other Vulkan games with it unfortunately, OpenGL version of GZDoom seems to work fine with it.
dpJudas
 
 
Posts: 2893
Joined: Sat May 28, 2016 1:01 pm

Re: Intel - iRIS Xe screen flickering, sprites not rendered at all

Post by dpJudas »

If OpenGL works flawlessly then why don't you just use that?

It requires a developer with iRIS Xe hardware to fix this I'm afraid. Impossible to guess what could be causing it without. You could try upgrade the drivers I guess - if you are lucky that will fix it.
Darkcrafter
Posts: 531
Joined: Sat Sep 23, 2017 8:42 am
Graphics Processor: nVidia with Vulkan support

Re: Intel - iRIS Xe screen flickering, sprites not rendered at all

Post by Darkcrafter »

Thanks for advice. Vulkan is considerably faster on some of my maps, that's at least on the desktop pc with ryzen 5 1600 and nvidia gtx 1060.
dpJudas
 
 
Posts: 2893
Joined: Sat May 28, 2016 1:01 pm

Re: Intel - iRIS Xe screen flickering, sprites not rendered at all

Post by dpJudas »

If you are willing to install the vulkan sdk you could try run gzdoom with "vk_debug 1" and see if it writes any errors into the console. If you are very lucky the validation layer will have noticed something. Make sure you turn off vk_debug afterwards though as it is very bad for performance.
Darkcrafter
Posts: 531
Joined: Sat Sep 23, 2017 8:42 am
Graphics Processor: nVidia with Vulkan support

Re: Intel - iRIS Xe screen flickering, sprites not rendered at all

Post by Darkcrafter »

So I installed Vulkan SDK and GZDoom only shows these warnings when the configurator is run in the background, with "vk_debug 1" cvar enabled and GZDoom restarted as required:

[vulkan warning] Vertex attribute at location 3 not consumed by vertex shader (stencil)
[vulkan warning] Vertex attribute at location 4 not consumed by vertex shader (stencil)
[vulkan warning] Vertex attribute at location 5 not consumed by vertex shader (stencil)
[vulkan warning] Vertex attribute at location 6 not consumed by vertex shader (stencil)
[vulkan warning] vertex shader writes to output location 0.0 which is not consumed by fragment shader. Enable VK_KHR_maintenance4 device extension to allow relaxed interface matching between input and output vectors. (stencil)
[vulkan warning] vertex shader writes to output location 1.0 which is not consumed by fragment shader. Enable VK_KHR_maintenance4 device extension to allow relaxed interface matching between input and output vectors. (stencil)
[vulkan warning] vertex shader writes to output location 9.0 which is not consumed by fragment shader. Enable VK_KHR_maintenance4 device extension to allow relaxed interface matching between input and output vectors. (stencil)

https://imgur.com/a/ey7gEGd
You do not have the required permissions to view the files attached to this post.
dpJudas
 
 
Posts: 2893
Joined: Sat May 28, 2016 1:01 pm

Re: Intel - iRIS Xe screen flickering, sprites not rendered at all

Post by dpJudas »

Bad news then - the validation layer did not detect anything wrong.

Return to “Vulkan Renderer Bugs”