GZDoom Script Error on a WAD

Need help running G/Q/ZDoom/ECWolf/Zandronum/3DGE/EDuke32/Raze? Did your computer break? Ask here.

Moderator: GZDoom Developers

Forum rules
Contrary to popular belief, we are not all-knowing-all-seeing magical beings!

If you want help you're going to have to provide lots of info. Like what is your hardware, what is your operating system, what version of GZDoom/LZDoom/whatever you're using, what mods you're loading, how you're loading it, what you've already tried for fixing the problem, and anything else that is even remotely relevant to the problem.

We can't magically figure out what it is if you're going to be vague, and if we feel like you're just wasting our time with guessing games we will act like that's what you're really doing and won't help you.
carbine
Posts: 2
Joined: Sat Oct 09, 2021 11:09 pm
Discord: carbine#1619

GZDoom Script Error on a WAD

Post by carbine »

I am having a script error when trying to load this WAD on GZDoom. I've never gotten an error like this before on any other mods I have run.
Here is a download for the WAD I am having the error with:
https://archive.org/details/abyssal_anti-social



Script warning, "anti-social.wad:DECORATE" line 273:
Tried to define class 'Plant12' more than once. Renaming class to 'Plant12@anti-social.wad@DECORATE'
Script warning, "anti-social.wad:DECORATE" line 596:
Tried to define class 'CONE' more than once. Renaming class to 'CONE@anti-social.wad@DECORATE'
Script warning, "anti-social.wad:DECORATE" line 9:
Icon 'CLP1C0' for 'AR15Clip' not found

Script warning, "anti-social.wad:DECORATE" line 153:
Tried to define class 'Clip' more than once. Renaming class to 'Clip@anti-social.wad@DECORATE'
Script warning, "anti-social.wad:DECORATE" line 567:
Tried to define class 'GlassShard' more than once. Renaming class to 'GlassShard@anti-social.wad@DECORATE'
Script warning, "anti-social.wad:DECORATE" line 598:
Tried to define class 'LightPosts' more than once. Renaming class to 'LightPosts@anti-social.wad@DECORATE'
Script warning, "anti-social.wad:DECORATE" line 251:
Icon 'CLP1C0' for '9mmClip' not found

Script warning, "anti-social.wad:DECORATE" line 488:
Icon 'CLP1C0' for 'SGClip' not found

Script warning, "anti-social.wad:DECORATE" line 491:
Tried to define class 'Shell' more than once. Renaming class to 'Shell@anti-social.wad@DECORATE'
Script warning, "anti-social.wad:DECORATE" line 674:
Icon 'CLP1C0' for 'MP5Clip' not found

Script warning, "anti-social.wad:DECORATE" line 677:
Tried to define class 'Clip' more than once. Renaming class to 'Clip@anti-social.wad@DECORATE'

Execution could not continue.

Script error, "anti-social.wad:DECORATE" line 677:
Script error, "anti-social.wad:DECORATE" line 677:
Tried to define class 'Clip' more than twice in the same file.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
Posts: 48040
Joined: Sat Jul 19, 2003 10:19 am
Location: Germany

Re: GZDoom Script Error on a WAD

Post by Graf Zahl »

That mod is broken. It redefines internal actors and then runs into problems. This won't work anymore with anything post ZDoom 2.8.1.
carbine
Posts: 2
Joined: Sat Oct 09, 2021 11:09 pm
Discord: carbine#1619

Re: GZDoom Script Error on a WAD

Post by carbine »

Graf Zahl wrote:That mod is broken. It redefines internal actors and then runs into problems. This won't work anymore with anything post ZDoom 2.8.1.
Would it work if I download an earlier version of ZDoom?
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
Posts: 48040
Joined: Sat Jul 19, 2003 10:19 am
Location: Germany

Re: GZDoom Script Error on a WAD

Post by Graf Zahl »

Like I said, it should still work with ZDoom 2.8.1 or early GZDoom 2.x versions. But you still may run into problems with savegames - this was the reason the code was changed.

Return to “Technical Issues”