lzdoom black screen on launch

Need help running G/Q/ZDoom/ECWolf/Zandronum/3DGE/EDuke32/Raze? Did your computer break? Ask here.

Moderator: GZDoom Developers

Forum rules
Contrary to popular belief, we are not all-knowing-all-seeing magical beings!

If you want help you're going to have to provide lots of info. Like what is your hardware, what is your operating system, what version of GZDoom/LZDoom/whatever you're using, what mods you're loading, how you're loading it, what you've already tried for fixing the problem, and anything else that is even remotely relevant to the problem.

We can't magically figure out what it is if you're going to be vague, and if we feel like you're just wasting our time with guessing games we will act like that's what you're really doing and won't help you.
Guest

lzdoom black screen on launch

Post by Guest »

Hi everyone,
so, I recently got a pretty old netbook with an intel atom n270 and decided to put linux (arch32) on it. When trying to launch the latest lzdoom with the "-glversion 2" option, lzdoom launches, but all I can see is a black window. I know the game is running because I can hear the sounds and music from the game, but I can't see anything. glxinfo tells me my OpenGL version is 1.4 and then the OpenGL ES version is 2.0. I also tried the latest build of zdoomle, but I still get a black window with the music and menu sounds playing. Is there any hope it can run (without going back to windows)?
User avatar
Rachael
Admin
Posts: 12957
Joined: Tue Jan 13, 2004 1:31 pm
Preferred Pronouns: She/Her

Re: lzdoom black screen on launch

Post by Rachael »

1.4 is too old even for LZDoom. I think you're reading the wrong value - 1.4 is one of the default values for the fallback drivers that Mesa sometimes uses.

You can try GZDoom-GLES. If your hardware supports GLES 2.0 it's new enough at least for that.

Return to “Technical Issues”