[Not a bug] Automap backround scaled incorrectly in Hexen

Bugs that have been investigated and resolved somehow.

Moderator: GZDoom Developers

Forum rules
Please don't bump threads here if you have a problem - it will often be forgotten about if you do. Instead, make a new thread here.

Automap backround scaled incorrectly in Hexen

Postby theleo_ua » Tue Jan 05, 2021 5:31 pm

Automap backround scaled incorrectly in Hexen

1) Run GZDoom 4.5.0 with hexen.wad
2) start hxvisit 01 and click TAB
3) type mapsco
4) observe, that it is hard to recognize the map (because background is upscaled too much): https://cdn.discordapp.com/attachments/ ... 013647.png
5) just another example for hexdd.wad: https://cdn.discordapp.com/attachments/ ... 013620.png

6) try steps 1-4 for GZDoom 3.4.1
7) observe, that it is not hard to recognize the map (because background is upscaled correctly): https://cdn.discordapp.com/attachments/ ... 014302.png

8) Overall outcome:

Actual result: hard to recognize the map:
https://cdn.discordapp.com/attachments/ ... 013647.png
https://cdn.discordapp.com/attachments/ ... 013620.png

Expected result: should be easy to recognize the map:
https://cdn.discordapp.com/attachments/ ... 014302.png


NOTE1: bug is not reproduced on low/medium and/or 4:3 resolutions, for example 1280x960. You need at least 1600x900 or 1920x1080 to reproduce this

NOTE2: if you change scaling factor (in options \ video mode) to 50%, map lines will become wider, and automap will become better, but pixel density will become worse than in 100% scaling (for example fonts will look like weird), so this is not an option as I see

NOTE3: I suggest to implement some extra scaling options (in "HUD / Saling" section):
a) automap lines scaling (how wide are map lines)
b) automap background scaling

GZDoom 4.5.0, Win7 x64, OpenGL
Should be reproduced with default settings, but if not, please tell me, I will upload my config
User avatar
theleo_ua
 
Joined: 07 Feb 2016
Location: Ukraine
Discord: discord.gg/xWhQcP7
Twitch ID: theleo_ua
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: ATI/AMD with Vulkan Support

Re: Automap backround scaled incorrectly in Hexen

Postby Enjay » Tue Jan 05, 2021 7:05 pm

The thing is that GZDoom is now more closely replicating the scaling of the background image as it was in the original DOS game. This was a recent fix for something that had been left untouched for many years and the background just kept getting smaller and smaller as screen resolutions got bigger and bigger.

Image

I guess it was less of a problem in 320x200 because the map lines were much thicker in comparison the the background.
User avatar
Enjay
Everyone is a moon, and has a dark side which he never shows to anybody. Twain
 
 
 
Joined: 15 Jul 2003
Location: Scotland

Re: Automap backround scaled incorrectly in Hexen

Postby Gez » Wed Jan 06, 2021 6:17 am

Yes, a line thickness setting is going to be needed with screen resolutions only ever getting larger.
Gez
 
 
 
Joined: 06 Jul 2007

Re: Automap backround scaled incorrectly in Hexen

Postby Nash » Wed Jan 06, 2021 6:26 am

It's been ~3 years, no one has stepped up yet. =D
User avatar
Nash
AKA Nash Muhandes! Twitter/Facebook/Youtube: nashmuhandes
 
 
 
Joined: 27 Oct 2003
Location: Kuala Lumpur, Malaysia
Twitch ID: nashmuhandes
Github ID: nashmuhandes


Return to Closed Bugs

Who is online

Users browsing this forum: No registered users and 0 guests