[Fixed] Scaling specific texture with a neative value disappears

Bugs that have been investigated and resolved somehow.

Moderator: GZDoom Developers

Re: Scaling specific texture with a neative value disappears

Postby Enjay » Thu May 07, 2020 1:02 pm

I also noticed that the texture was scaled in the X direction (5. something if I recall). I can't check it right now but does changing/removing the X scale factor change anything?
User avatar
Enjay
Everyone is a moon, and has a dark side which he never shows to anybody. Twain
 
 
 
Joined: 15 Jul 2003
Location: Scotland

Re: Scaling specific texture with a neative value disappears

Postby Tormentor667 » Thu May 07, 2020 1:35 pm

Enjay wrote:I also noticed that the texture was scaled in the X direction (5. something if I recall). I can't check it right now but does changing/removing the X scale factor change anything?

I didn't try 5 but 4.0, 1.1, -2.0 and -0.1. It disappeared if it was a negative value, it appeared when positive or the "wrap" flag was active.
User avatar
Tormentor667
needs more detail
 
Joined: 16 Jul 2003
Location: Germany

Re: Scaling specific texture with a neative value disappears

Postby Enjay » Thu May 07, 2020 2:24 pm

OK, a little more information. The translucency of the texture is part of the problem. If I resave the image as fully opaque,
Image Image
original versus edit

it works (this is in an unedited map).

I noticed that the line also has translucency so I tried switching that off instead of changing the texture. The texture did not appear as visible in the map. i.e. the fault persisted.


And just to be clear, the -1 Y scaling is still part of the equation too because if I edit the lines to remove that, the texture is visible.

That is the map edited so that those lines have a y scale of 1 instead of -1. No other changes (to the map or the texture) were made.


Tormentor667 wrote:I didn't try 5 but 4.0, 1.1, -2.0 and -0.1. It disappeared if it was a negative value, it appeared when positive or the "wrap" flag was active.

I think that maybe you picked me up wrongly? I meant that in your map, the textures in question also have an x-scale value of 5-point-something (5.57 or 5.65) and I was wondering it that would have any impact. I tried setting it to 1. This had no impact on the problem. (i.e. the problem was still there.)
User avatar
Enjay
Everyone is a moon, and has a dark side which he never shows to anybody. Twain
 
 
 
Joined: 15 Jul 2003
Location: Scotland

Re: Scaling specific texture with a neative value disappears

Postby Tormentor667 » Fri May 08, 2020 1:54 am

Enjay wrote:OK, a little more information. The translucency of the texture is part of the problem. If I resave the image as fully opaque, original versus edit

We are getting closer :-) But this is obviously an engine bug. I tend to save images for these kind of special effects with an alpha channel to avoid being forced to use additive translucency when having an opaque image. That way you can also do other crazy things that wouldn't be possible with a black background.
User avatar
Tormentor667
needs more detail
 
Joined: 16 Jul 2003
Location: Germany

Re: Scaling specific texture with a neative value disappears

Postby Enjay » Fri May 08, 2020 4:34 am

Oh yes, absolutely, I wasn't trying to say that it isn't an engine bug. I was merely mentioning something that I'd found that might help track down where the problem lies.
User avatar
Enjay
Everyone is a moon, and has a dark side which he never shows to anybody. Twain
 
 
 
Joined: 15 Jul 2003
Location: Scotland

Re: Scaling specific texture with a neative value disappears

Postby Tormentor667 » Sun May 17, 2020 12:41 pm

Sorry for bumping this but has this already been resolved somehow?
User avatar
Tormentor667
needs more detail
 
Joined: 16 Jul 2003
Location: Germany

Re: Scaling specific texture with a neative value disappears

Postby Graf Zahl » Sun May 17, 2020 1:30 pm

Have you seen this thread being moved to 'closed bugs'?
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: Scaling specific texture with a neative value disappears

Postby Tormentor667 » Sun May 17, 2020 2:11 pm

Sorry for asking 😄 A „no, we haven’t investigated this any further“ would have been ok as well ;)
User avatar
Tormentor667
needs more detail
 
Joined: 16 Jul 2003
Location: Germany

Re: Scaling specific texture with a neative value disappears

Postby Graf Zahl » Mon May 25, 2020 12:49 pm

I'M afraid but with this map I cannot investigate this. Please post something smaller where I a) do not have to search the map for the problem spot and b) only contains a single wall that's causing the glitch.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: Scaling specific texture with a neative value disappears

Postby Tormentor667 » Mon May 25, 2020 3:30 pm

All I can currently do is this description for where to find the right spot, I hope that helps for the investigation.

Link: https://www.realm667.com/index.php/en/d ... -austerity
Map: MAP02
Coordinates: X 930 | Y 350
Example line: 1041
Texture in question: GLOW_W.PNG
User avatar
Tormentor667
needs more detail
 
Joined: 16 Jul 2003
Location: Germany

Re: Scaling specific texture with a neative value disappears

Postby Graf Zahl » Wed Jun 03, 2020 2:31 pm

fixed. This fell victim to an optimization to reduce empty space in mid textures. The code for that was written for unmirrored textures only.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: Scaling specific texture with a neative value disappears

Postby Tormentor667 » Thu Jun 04, 2020 7:48 am

Thanks kindly for the fix Graf Zahl!
User avatar
Tormentor667
needs more detail
 
Joined: 16 Jul 2003
Location: Germany

Previous

Return to Closed Bugs

Who is online

Users browsing this forum: Gez and 0 guests