(4.3.3) Gus midi Audio Issues

Is there something that doesn't work right in the latest GZDoom? Post about it here.

Moderator: GZDoom Developers

Forum rules
Please construct and post a simple demo whenever possible for all bug reports. Please provide links to everything.

If you can include a wad demonstrating the problem, please do so. Bug reports that include fully-constructed demos have a much better chance of being investigated in a timely manner than those that don't.

Please make a new topic for every bug. Don't combine multiple bugs into a single topic. Thanks!

(4.3.3) Gus midi Audio Issues

Postby Ghostrider231 » Thu Feb 20, 2020 11:34 pm

When I was launching gzdoom 4.3.3 with gus as my midi device...
Any midi that is played under GUS will either be very deafeningly loud and glitchy or just plain mute.


Also yes, I've tested this in the latest dev builds, and it still happens there.

However If I launch an older version of gzdoom (ex: 4.1.3), the GUS audio works and sounds as intended. (Even though it doesn't sound exactly like doom 2 bfg's but whatever)

You can test this with base doom 2, doom, heretic, hexen, or etc. (Demo wads/pk3s aren't needed)

And both of these use the exact same gus audio setup.

Steps to how to repeat this issue:
1. Use the gus setup that I've provided. (if you already had gus installed and ready, than skip this step)
2. Launch Gzdoom (any IWAD that has midi songs, like doom 2)
3. Make sure GUS is your current midi device.
4. Start a new game. (Title music doesn't repeat)
5. The Entryway midi becomes very loud and glitchy. (If you are using 4.1.3, then it will sound normal)

Quicker method:
You can also use the "changemus d_runnin" command in the console. (Or whatever song is a midi file)



Examples:

(Gzdoom 4.1.3, Gus works as intended)



(Gzdoom 4.3.3, LOUD SOUND WARNING)


Ignore the error messages in the example videos, those messages aren't related to this issue.

The Gus setup used
User avatar
Ghostrider231
Mah legs argh
 
Joined: 15 Aug 2014
Location: The Great Depths and Beyond.
Graphics Processor: nVidia (Modern GZDoom)

Re: (4.3.3) Gus midi Audio Issues

Postby Octavia Siddlehudging » Sat Mar 28, 2020 11:39 pm

I have the same issue but it also doesn’t work on 4.1.3.
Octavia Siddlehudging
 


Return to Bugs

Who is online

Users browsing this forum: No registered users and 0 guests