Weird (Renderer?) Visual Glitch

Bugs with GZDoom Vintage builds. Same rules apply as with all other bug reports fora.

Moderator: GZDoom Developers

Forum rules
Please construct and post a simple demo whenever possible for all bug reports. Please provide links to everything.

If you can include a wad demonstrating the problem, please do so. Bug reports that include fully-constructed demos have a much better chance of being investigated in a timely manner than those that don't.

Please make a new topic for every bug. Don't combine multiple bugs into a single topic. Thanks!
User avatar
ReX
Posts: 1561
Joined: Tue Aug 05, 2003 10:01 am
Location: Quatto's Palace

Weird (Renderer?) Visual Glitch

Post by ReX »

I just encountered a weird visual glitch. Looking at an area at a certain angle shows everything as it ought to be. Lowering the field of view fractionally really messes up the view. Lowering the field of view again resolves the issue. So it's only when the view falls within a narrow angular range. This problem does not seem to happen from every possible viewpoint, but I haven't tried changing position too much.

GZDoom v3.7.2 Legacy; hardware acceleration (not an external video card)

Here is a normal view of the scene:
ZD_Normal.jpg
Here is the messed up view of the scene:
ZD_Messy.jpg
You do not have the required permissions to view the files attached to this post.
User avatar
Rachael
Admin
Posts: 13107
Joined: Tue Jan 13, 2004 1:31 pm
Preferred Pronouns: She/Her

Re: Weird (Renderer?) Visual Glitch

Post by Rachael »

First and most obvious question is going to be - what is your GPU?

We should also know your operating system and what kind of CPU you have.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
Posts: 48375
Joined: Sat Jul 19, 2003 10:19 am
Location: Germany

Re: Weird (Renderer?) Visual Glitch

Post by Graf Zahl »

Also important:

What map?
What does the modern build do?
User avatar
ReX
Posts: 1561
Joined: Tue Aug 05, 2003 10:01 am
Location: Quatto's Palace

Re: Weird (Renderer?) Visual Glitch

Post by ReX »

@Rachael: I can’t check right now but will send info as soon as I can.

@Graf: 1. It’s a custom map (WIP), which I can send you if needed
2. I haven’t used the newest build, but I’ll download, try out, and report back
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
Posts: 48375
Joined: Sat Jul 19, 2003 10:19 am
Location: Germany

Re: Weird (Renderer?) Visual Glitch

Post by Graf Zahl »

I'll still need the map to analyze the problem.
User avatar
Rachael
Admin
Posts: 13107
Joined: Tue Jan 13, 2004 1:31 pm
Preferred Pronouns: She/Her

Re: Weird (Renderer?) Visual Glitch

Post by Rachael »

Rex seems to do a lot of hit and run forum visits. He'll be here for a few days and then he'll disappear for a couple months. I'm hoping that he won't forget about this, though.

I'm just letting you know, in hoping to make it less likely you'll close this.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
Posts: 48375
Joined: Sat Jul 19, 2003 10:19 am
Location: Germany

Re: Weird (Renderer?) Visual Glitch

Post by Graf Zahl »

Still no response. :(
But seeing that this is the vintage build and ReX having said he's still using old hardware, I am now moving this to the proper subforum.

Return to “Vintage Build Bugs”