Game lags terribly on Software Rendering mode

Need help running G/Q/ZDoom/ECWolf/Zandronum/3DGE/EDuke32/Raze? Did your computer break? Ask here.

Moderator: GZDoom Developers

Forum rules
Contrary to popular belief, we are not all-knowing-all-seeing magical beings!

If you want help you're going to have to provide lots of info. Like what is your hardware, what is your operating system, what version of GZDoom/LZDoom/whatever you're using, what mods you're loading, how you're loading it, what you've already tried for fixing the problem, and anything else that is even remotely relevant to the problem.

We can't magically figure out what it is if you're going to be vague, and if we feel like you're just wasting our time with guessing games we will act like that's what you're really doing and won't help you.
Erenussocrates
Posts: 36
Joined: Thu Apr 21, 2016 3:44 pm

Game lags terribly on Software Rendering mode

Post by Erenussocrates »

I haven't been playing Doom for a while up until now. When I launched the game and started playing today, the game had terrible FPS (I didn't have FPS counter, but it was definitely noticable, somewhere around 15 fps) I downloaded the latest GZDoom stable update, and it was still doing the same. Then I tried switching to hardware mode, and the lag was gone.

Needless to say, it wasn't like this on my PC before.
User avatar
Rachael
Posts: 13621
Joined: Tue Jan 13, 2004 1:31 pm
Preferred Pronouns: She/Her

Re: Game lags terribly on Software Rendering mode

Post by Rachael »

First of all, this is not a bug.

Secondly, you have given absolutely no information here. We need to know your CPU and GPU type, what your vid_glswfb setting is, and what operating system you are using.

This issue is unsolvable without this critical information.
Erenussocrates
Posts: 36
Joined: Thu Apr 21, 2016 3:44 pm

Re: Game lags terribly on Software Rendering mode

Post by Erenussocrates »

I don't care, the first category I've seen which might have been a right place to post was there, so I posted there. Also, from my experience it looked pretty much like a bug, since it didn't use to do that. It doesn't matter anyway.

I have:

Operating System
Windows 10 Home Single Language 64-bit

CPU
Intel Core i7 6700HQ @ 2.60GHz 50 °C
Skylake 14nm Technology

RAM
16,0GB

Motherboard
MONSTER ABRA A5 V7.1 (U3E1)

Graphics
Generic PnP Monitor (1920x1080@60Hz)
Intel HD Graphics 530 (CLEVO/KAPOK Computer)
4095MB NVIDIA GeForce GTX 960M (CLEVO/KAPOK Computer) 43 °C
ForceWare version: 382.05
SLI Disabled

Storage
223GB INTEL SSDSCKHW240A4 (SSD) 39 °C
931GB Hitachi HGST HTS721010A9E630 (SATA) 41 °C

Optical Drives
DiscSoft Virtual SCSI CdRom Device
DiscSoft Virtual SCSI CdRom Device
DiscSoft Virtual SCSI CdRom Device
DiscSoft Virtual SCSI CdRom Device
DiscSoft Virtual SCSI CdRom Device
DiscSoft Virtual SCSI CdRom Device
DiscSoft Virtual SCSI CdRom Device
TSSTcorp CDDVDW SU-208GB

Audio
Realtek High Definition Audio

I don't know what that other setting is and I don't know where to look at that.
User avatar
Rachael
Posts: 13621
Joined: Tue Jan 13, 2004 1:31 pm
Preferred Pronouns: She/Her

Re: Game lags terribly on Software Rendering mode

Post by Rachael »

It appears this is a laptop that uses Optimus. There are known issues with that.

There is no real solution to the problem, but there are a number of work-arounds that you can try:

If you're running Windowed mode (NOT borderless):

Workaround 1: In GZDoom, you can turn off VSync and enforce a framerate cap instead. You may use the console for this:

Code: Select all

vid_vsync false
vid_maxfps 59
The actual FPS will be 63 or so, because of how the timing code works, but it works. DWM.exe enforces VSync, anyhow, unfortunately.

If you're using Borderless and/or Fullscreen:

Workaround 2: GZDoom functions better when VSync is forced on, with Optimus in either fullscreen mode.

Code: Select all

vid_vsync true
This will work regardless of windowed setting:

Workaround 3: You can force GZDoom to use your Intel processor. This is, again, accomplished with the console as follows:

Code: Select all

vid_gpuswitch 2
Set it to 0 to use the default again, or to let NVidia decide.
Erenussocrates
Posts: 36
Joined: Thu Apr 21, 2016 3:44 pm

Re: Game lags terribly on Software Rendering mode

Post by Erenussocrates »

Yep, it's a laptop. I'm using NVidia, I don't know what optimus is though.
User avatar
Rachael
Posts: 13621
Joined: Tue Jan 13, 2004 1:31 pm
Preferred Pronouns: She/Her

Re: Game lags terribly on Software Rendering mode

Post by Rachael »

I edited my previous post after doing a bit of research on your motherboard.
Erenussocrates
Posts: 36
Joined: Thu Apr 21, 2016 3:44 pm

Re: Game lags terribly on Software Rendering mode

Post by Erenussocrates »

Oh yep, the third option did work. I hope I won't install a mod that might require my other, more powerful GPU though. But in any case, thanks
User avatar
Rachael
Posts: 13621
Joined: Tue Jan 13, 2004 1:31 pm
Preferred Pronouns: She/Her

Re: Game lags terribly on Software Rendering mode

Post by Rachael »

Sure thing. :)
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
Posts: 49096
Joined: Sat Jul 19, 2003 10:19 am
Location: Germany

Re: Game lags terribly on Software Rendering mode

Post by Graf Zahl »

Since this is software rendering, I'm wondering if the issue will be resolved by the new render backend unification.

How does hardware rendering perform on this system? Has it similar problems?
User avatar
Rachael
Posts: 13621
Joined: Tue Jan 13, 2004 1:31 pm
Preferred Pronouns: She/Her

Re: Game lags terribly on Software Rendering mode

Post by Rachael »

@ Graf:

I suspect the problem is a large resolution display reveals a rather ugly underlying problem. Optimus syncs utterly terribly in DWM.exe (thanks again for the poor design choices, Microsoft!) and this can actually be hidden when frame rates are very high, like more than 4 times the display's refresh rate. Since the software renderer is not that fast, that means a lower frame rate obviously (still technically >60 but not visibly, and just barely at that even), but also much poorer sync.

Having an Optimus laptop myself, I have experienced a myriad of these sync issues. If my suspicions are correct, the only thing that happened here was in the OP's case the hardware renderer was running quick enough that he did not notice the frame lag that was actually happening.

However, if I am wrong then you might actually be correct since GZDoom currently defaults to rendering on an ancient Direct3D backend. If that's the case, and this is an issue I've never experienced with Optimus, then you'd be right that the unification would fix the problem - but it seems to me rather unlikely that will be the case.

Basically, what it comes down to is DWM.exe is a shitty piece of software.

Also - on a more technical note, if you want to know what Optimus actually does - it's basically using the Intel processor entirely for both the display adapter and the video memory, as well as copying the framebuffer from the NVidia render. The NVidia chip functions as nothing more than a D3D/OGL/Vulkan drawer, and it renders to a texture that Intel picks up and places inside of its video memory using accelerated 2D functions. If the sync events are out of whack, you can imagine how this would cause terrible lag.

Return to “Technical Issues”