Trouble compiling QZDoom

Archive of the old editing forum
Forum rules
Before asking on how to use a ZDoom feature, read the ZDoom wiki first. This forum is archived - please use this set of forums to ask new questions.
User avatar
Jaxxoon R
Posts: 772
Joined: Sun May 04, 2014 7:22 pm

Trouble compiling QZDoom

Post by Jaxxoon R »

Currently trying to compile QZDoom. I'm pretty sure I've downloaded and installed everything the wiki guide says to, but when I go to use CMake, it tells me:

Failed to run MSBuild command:

MSBuild.exe

to get the value of VCTargetsPath:

I did install Visual Studio 2017 instead of 2015 (since it seems like Microsoft tried its damnedest to make getting 2015 a pain). But at the time I figured it couldn't possibly hurt, right? Is this what's causing the issue? If it is, then does anyone know how I can get the correct version of Visual Studio? I'm still new to the whole compiling thing, I've only compiled GZDoom once and that was a couple of years back.
User avatar
Rachael
Admin
Posts: 12953
Joined: Tue Jan 13, 2004 1:31 pm
Discord: Rachael#3767
Twitch ID: madamerachelle
Github ID: madame-rachelle
Preferred Pronouns: She/Her

Re: Trouble compiling QZDoom

Post by Rachael »

Does compiling GZDoom work?

At the moment GZDoom is more updated - it has QZDoom merged in and I try to keep the code in a useable state with the Travis CI notifications.
_mental_
 
 
Posts: 3774
Joined: Sun Aug 07, 2011 4:32 am

Re: Trouble compiling QZDoom

Post by _mental_ »

Please configure it to a new build directory and post whole output.
What's branch and commit you are using?
User avatar
Jaxxoon R
Posts: 772
Joined: Sun May 04, 2014 7:22 pm

Re: Trouble compiling QZDoom

Post by Jaxxoon R »

On a whim I tried setting it to configure for VS2017 instead of VS2015 and it seems to work fine :shrug: CMake creates the build project and Visual Studio compiles it all without issue.
User avatar
Jaxxoon R
Posts: 772
Joined: Sun May 04, 2014 7:22 pm

Re: Trouble compiling QZDoom

Post by Jaxxoon R »

Seems there's been unintended consequences. For some reason all the executables I compile have really bad performance, even after setting the build type from "Debug" to "Release."

Return to “Editing (Archive)”