New repo for old ZDoom versions [2.1.8 CL release]

ZDoom LE, Pentium 133's, Windows 98, and DOS 3.1 all go here! A bygone era, of particular interest to some folks.

New repo for old ZDoom versions [2.1.8 CL release]

Postby drfrag » Tue Mar 17, 2020 6:41 am

I've created a new repository for old versions (i forked the one by AlexMax for the ancient no repo versions and combined it with his mirror of the old SVN repo). So in theory i can cherry-pick on top of ancient versions. What about the license? AlexMax repo had no license.
From the ZDuke thread:
randi wrote:I am rather sad that it now spits out an error that DirectDraw returned no display modes

Now i get the "DirectDraw returned no display modes" error on Win10 too and i know i can use an emulator (DXGL) but there are some problems.
First i wanted to fix 2.0.98 but it didn't compile with modern VS, something about using friend with templates (looks really bad) and an internal compiler error. So wall of errors and even if it did compile i know there would be other problems (reported no gravity and graphics corruption with gcc...).
Since ZDoom classic was not very good i've recreated it and done a 2.1.8 pirated version without my junk. For the 2.1.8 branch i've merged the preliminary D3D backend and works well, i applied some minor fixes and got rid of the Bison dependency too. I use NASM 0.9. With TDM-GCC the release build crashes on exit after adding D3D no surprise here.
BUT with VS 2017 there's some misoptimization causing serious issues. I've tried IA32, using strict FP model and disabling intrinsics but they didn't help. You can't hit monsters with hitscan weapons nor damage them with melee and they can see you though walls. May be even it's a compiler bug but i don't know where to look at. :x
I've asked Blzut3 may be he can help.
https://github.com/drfrag666/zdoom-old
https://github.com/drfrag666/zdoom-old/commits/2.1.8
Last edited by drfrag on Sat Mar 28, 2020 7:13 am, edited 1 time in total.
User avatar
drfrag
Os voy a romper a pedazos!
Vintage GZDoom Developer
 
Joined: 23 Apr 2004
Location: Spain
Discord: drfrag#3555
Github ID: drfrag666

Re: New repo for old ZDoom versions

Postby Redneckerz » Tue Mar 17, 2020 9:14 am

What i love to see, is a repo of old versions that were the last in line when it comes to specific OpenGL version support. I know you maintain a few builds merging older OpenGL renderers with other improvements, but i have yet to find a repo that lists the 4-5 versions having the last OpenGL 1.4, 2.0, etc support.

Is this a possible goal of the repository?

Another possible use might be something TDRR is working on, GShadow Resurrected. It was attempted to include this built-in into a Zandronum build, but apparently it relies on a broken function present since ZDoom 2.0.96x (the Community Build). Something like QZDoomish like features, but for legacy OpenGL (GShadow works through pure DECORATE and ACS).

Obviously these can just be found by the ZDoom files repository, but i am missing an easy-to-redirect set of official builds that target specific OpenGL versions.

Lastly, ill soon pull up a files archive of hard-to-find one-off and older ZDoom builds and other stuff., the majority is likely already integrated into current builds anyway, but for preservation purposes, its interesting to keep these builds archived somehow, if only for Wolfman and the Mod Request crew to link to that archive instead of reupping to Mediafire.
User avatar
Redneckerz
To it's ports i may have seen
Spotlight Team
 
Joined: 25 Nov 2019
Discord: Redneckerz#8399
Operating System: Windows Vista/7/2008 64-bit
Graphics Processor: nVidia (Legacy GZDoom)

Re: New repo for old ZDoom versions

Postby drfrag » Wed Mar 18, 2020 12:16 pm

For this one? Of course not, it's just to preserve old ZDoom versions. In theory with the source it's enough but now there are problems with modern compilers and VS at that time was not free, and even using the same version with a different configuration could give problems AFAIR. At least they can be compiled with an old MinGW.
I believe most if not all binaries are already on ZDoom.org. We found quite a few some time ago at sourceforge:
viewtopic.php?f=90&t=59727&p=1043426

On 2.1.8 i haven't tried MinGW-w64 yet. I've fixed compilation with modern SDKs (i was using v141_xp) and managed to run a code analysis. The analysis seems useless tough and it was tricky to trigger it as the feature was mostly broken in VS 2017. The problem probably is in p_map.cpp? Debug builds are okay and i bet VS 2013 would too but it's dead. Any ideas? I'd like to do a v141_xp release as i believe that version was a milestone.
drfrag wrote:You can't hit monsters with hitscan weapons nor damage them with melee and they can see you though walls.

@Graf Zahl or @randi could know what's going on with those symptoms. :?
User avatar
drfrag
Os voy a romper a pedazos!
Vintage GZDoom Developer
 
Joined: 23 Apr 2004
Location: Spain
Discord: drfrag#3555
Github ID: drfrag666

Re: New repo for old ZDoom versions

Postby Redneckerz » Wed Mar 18, 2020 3:04 pm

drfrag wrote:For this one? Of course not, it's just to preserve old ZDoom versions. In theory with the source it's enough but now there are problems with modern compilers and VS at that time was not free, and even using the same version with a different configuration could give problems AFAIR. At least they can be compiled with an old MinGW.
I believe most if not all binaries are already on ZDoom.org. We found quite a few some time ago at sourceforge:
viewtopic.php?f=90&t=59727&p=1043426

So an extra repository then. Interesting post there - It has quite a few bits, still misses a few things aswell (Like the aforementioned DOS source of 1.23b25 i spoke about on Discord)

The repository i am going for is not so much about the official versions of ZDoom, rather, offspring versions made by the community, hard to-come by files and other experimental stuff and more. There might be some official stuff in there, but when the time comes ill ramp up a post here. For now i have just been setting it up and getting text templates running as i feel each .zip needs a description text describing what it is.

In order to do that with some consistency, i have written a template text based on UPDTEMPL.txt of /idgames. That way i can write consistent descriptions for every file i put up there.
User avatar
Redneckerz
To it's ports i may have seen
Spotlight Team
 
Joined: 25 Nov 2019
Discord: Redneckerz#8399
Operating System: Windows Vista/7/2008 64-bit
Graphics Processor: nVidia (Legacy GZDoom)

Re: New repo for old ZDoom versions

Postby drfrag » Wed Mar 18, 2020 4:28 pm

Redneckerz wrote:the aforementioned DOS source of 1.23b25

And i already told you that was just a different end of line format (DOS vs Unix). For DOS there was a late eternity version @vogons besides MBF 2.04.
About OpenGL i know that the last version officialy supporting 1.3 was 1.84 and for 1.4 it was 1.8.6. For 1.1 i dunno but i actually ran 1.0.18 (the source was lost but i recreated it and fixed a very serious bug in 1.0.17 BTW) on an intel 810.
User avatar
drfrag
Os voy a romper a pedazos!
Vintage GZDoom Developer
 
Joined: 23 Apr 2004
Location: Spain
Discord: drfrag#3555
Github ID: drfrag666

Re: New repo for old ZDoom versions

Postby Graf Zahl » Thu Mar 19, 2020 1:14 am

drfrag wrote:. For 1.1 i dunno but i actually ran 1.0.18 (the source was lost but i recreated it and fixed a very serious bug in 1.0.17 BTW) on an intel 810.


Keep in mind that GZDoom required stencil buffers from the very start and AFAIK they only became a core feature in 1.3. That's why I always stated the minimum requirements as OpenGL 1.3.
Also don't forget that there never were any mainstream graphics cards that only supported GL 1.1, we are talking 5 years before the first release here!
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: New repo for old ZDoom versions

Postby Redneckerz » Thu Mar 19, 2020 7:45 am

drfrag wrote: And i already told you that was just a different end of line format (DOS vs Unix).

Que? Didn't see that specifically, but ill go with it.

drfrag wrote:About OpenGL i know that the last version officialy supporting 1.3 was 1.84 and for 1.4 it was 1.8.6. For 1.1 i dunno but i actually ran 1.0.18 (the source was lost but i recreated it and fixed a very serious bug in 1.0.17 BTW) on an intel 810.

But this is good stuff :) OpenGL 1.2 was never a supported feature officially (as per what Graf says) but ZDoom LE supported it according to one of your posts (I don't have the link laying around). EDIT: I do.

Either way, this is a good summary of feature tiers, so i am glad for all your legacy work you made there. :)
User avatar
Redneckerz
To it's ports i may have seen
Spotlight Team
 
Joined: 25 Nov 2019
Discord: Redneckerz#8399
Operating System: Windows Vista/7/2008 64-bit
Graphics Processor: nVidia (Legacy GZDoom)

Re: New repo for old ZDoom versions

Postby Graf Zahl » Thu Mar 19, 2020 8:09 am

drfrag can claim endlessly that it works with GL 1.2, but that doesn't change anything about the fact that GZDoom does not fully work on real GL 1.2 hardware - these NVidia cards supported a superset of 1.2 that included the features not present in core 1.2.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: New repo for old ZDoom versions

Postby Redneckerz » Thu Mar 19, 2020 11:31 am

Graf Zahl wrote:drfrag can claim endlessly that it works with GL 1.2, but that doesn't change anything about the fact that GZDoom does not fully work on real GL 1.2 hardware - these NVidia cards supported a superset of 1.2 that included the features not present in core 1.2.

Frag claimed 1.2 compatibility with an older driver per that post (It is not specified what driver used) and i reckon a similar story would inhibit the illustrious 1.1 compatibility.

For completeness sakes, What are the official versions that last dropped an OpenGL tier in GZ? So 1.8.6 - Last to support OpenGL 1.4. and so on.

I know that around 1.9 OpenGL2 got introduced, but perhaps you have a proper list, or know where to find one. This is also for my own sake partially, as i have been testing various old ZDoom and GZDoom based builds recently for a Spotlight article in the making, so stuff like Foreverhood, or Harmony, along with several source based modifications from the old age.

Instead of accumulating info from various posts here and on DRDTeam - I prefer hearing it from the man himself. :wink:
User avatar
Redneckerz
To it's ports i may have seen
Spotlight Team
 
Joined: 25 Nov 2019
Discord: Redneckerz#8399
Operating System: Windows Vista/7/2008 64-bit
Graphics Processor: nVidia (Legacy GZDoom)

Re: New repo for old ZDoom versions

Postby Graf Zahl » Thu Mar 19, 2020 11:46 am

Redneckerz wrote:
Graf Zahl wrote:drfrag can claim endlessly that it works with GL 1.2, but that doesn't change anything about the fact that GZDoom does not fully work on real GL 1.2 hardware - these NVidia cards supported a superset of 1.2 that included the features not present in core 1.2.

Frag claimed 1.2 compatibility with an older driver per that post (It is not specified what driver used) and i reckon a similar story would inhibit the illustrious 1.1 compatibility.

For completeness sakes, What are the official versions that last dropped an OpenGL tier in GZ? So 1.8.6 - Last to support OpenGL 1.4. and so on.



I never really kept track of that. At the time these older versions were dropped the only remaining hardware in use were some Intel chipsets, as both AMD and NVidia had GL 2.0 support when the first GZDoom version came out and none of these cards existed anymore in systems I considered supported. And we all know that Intel's graphics solutions of this vintage are 100% useless for playing games with hardware acceleration.
To be blunt, it''s the kind of vintage support that costs a lot of time and effort while really serving nobody. That's why it was dropped, after all.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: New repo for old ZDoom versions

Postby Redneckerz » Thu Mar 19, 2020 11:59 am

Graf Zahl wrote:I never really kept track of that. At the time these older versions were dropped the only remaining hardware in use were some Intel chipsets, as both AMD and NVidia had GL 2.0 support when the first GZDoom version came out and none of these cards existed anymore in systems I considered supported. And we all know that Intel's graphics solutions of this vintage are 100% useless for playing games with hardware acceleration.

Tell me about it. I have thin clients laying around with Intel GMA based stuff and Chrome9 stuff. If i was ever to run GZ on those, i would be looking at versions approaching 15 years of age. I would be better off with a different port that keeps codebase recent but the OpenGL requirement equally low.

Graf Zahl wrote:To be blunt, it''s the kind of vintage support that costs a lot of time and effort while really serving nobody. That's why it was dropped, after all.

I knew i forgot to add something to my previous post - Part of why i requested such a list is because of some talk with Zandronum folks, which as you know, runs GZ 1.8.6. Within the GZDoom realm, there are still use cases that rely on older/legacy hardware.

But there is one GZ based build that, atleast on the visual front targets high end - The custom build utilized in Project Tremors by Indecom4000. Sadly there is just not much information around besides a few threads and some amazing screenshots. Its a poster child of GZ visuals but a lot of it (as i understand) is custom work. ZDoom link here, DW link here.
User avatar
Redneckerz
To it's ports i may have seen
Spotlight Team
 
Joined: 25 Nov 2019
Discord: Redneckerz#8399
Operating System: Windows Vista/7/2008 64-bit
Graphics Processor: nVidia (Legacy GZDoom)

Re: New repo for old ZDoom versions

Postby drfrag » Thu Mar 19, 2020 4:34 pm

So officially it's 1.8.4 for 1.3 and 1.8.6 for 1.4, and version 3.4.1 for 2.0.
The version string said 1.2 something and it was a TNT2 m64 with a early driver. I tested on much crappier hardware and it was not too bad, even the legendary voodoo 3 with MesaFX and it sucked mainly becouse of the 256x256 texture size limit. 1.0.18 at least ran on 1.1 hardware and i don't remember major problems on the intel, it crashed on the savage 3d due to a driver bug and there's a report here.
User avatar
drfrag
Os voy a romper a pedazos!
Vintage GZDoom Developer
 
Joined: 23 Apr 2004
Location: Spain
Discord: drfrag#3555
Github ID: drfrag666

Re: New repo for old ZDoom versions

Postby drfrag » Thu Mar 19, 2020 4:41 pm

Some progress, i've fixed the MinGW makefile (made MinGW-w64 builds crash) and the crash on exit with MinGW.
Here's a release test build. Seems it's very fast and also has extra video modes. The VS build is bad but i included it to show those issues, any help would be appreciated. :3:
Edit: link removed. See below.
Last edited by drfrag on Sat Mar 21, 2020 6:15 am, edited 2 times in total.
User avatar
drfrag
Os voy a romper a pedazos!
Vintage GZDoom Developer
 
Joined: 23 Apr 2004
Location: Spain
Discord: drfrag#3555
Github ID: drfrag666

Re: New repo for old ZDoom versions

Postby Redneckerz » Thu Mar 19, 2020 6:42 pm

drfrag wrote:So officially it's 1.8.4 for 1.3 and 1.8.6 for 1.4, and version 3.4.1 for 2.0.
The version string said 1.2 something and it was a TNT2 m64 with a early driver. I tested on much crappier hardware and it was not too bad, even the legendary voodoo 3 with MesaFX and it sucked mainly becouse of the 256x256 texture size limit. 1.0.18 at least ran on 1.1 hardware and i don't remember major problems on the intel, it crashed on the savage 3d due to a driver bug and there's a report here.

Was it not 3.3.1? Thats the last version atleast that references GL2 on forum atleast.

drfrag wrote:Some progress, i've fixed the MinGW makefile (made MinGW-w64 builds crash) and the crash on exit with MinGW.
Here's a release test build. Seems it's very fast and also has extra video modes. The VS build is bad but i included it to show those issues, any help would be appreciated. :3:
https://gofile.io/?c=BEnt5r

I can give this a whirl on the weekend or monday. Anything in particular i should look for?
User avatar
Redneckerz
To it's ports i may have seen
Spotlight Team
 
Joined: 25 Nov 2019
Discord: Redneckerz#8399
Operating System: Windows Vista/7/2008 64-bit
Graphics Processor: nVidia (Legacy GZDoom)

Re: New repo for old ZDoom versions

Postby Graf Zahl » Fri Mar 20, 2020 1:43 am

3.4 works on GL 2, but suffers from performance regressions because it did not like the changes I made to make it run faster on modern hardware.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany

Next

Return to Legacy Discussion

Who is online

Users browsing this forum: No registered users and 0 guests