Page 1 of 1

Card that only supports "software mode" of opengl2 on gz?

PostPosted: Thu Mar 15, 2018 9:05 am
by invictius
Bought a dual-voltage agp fx5600 for benchmarking and just assumed from wikipedia that it was opengl 2.1 but apparently it's "software mode" with latest drivers. Can I expect big problems or will gz handle it well?

Re: Card that only supports "software mode" of opengl2 on gz

PostPosted: Thu Mar 15, 2018 9:07 am
by Rachael
GZDoom does not run OpenGL in Software mode on anything below OpenGL 3.0.

For that it either uses Direct3D or whatever unaccelerated framebuffer the operating system will provide.

Re: Card that only supports "software mode" of opengl2 on gz

PostPosted: Thu Mar 15, 2018 9:13 am
by invictius
Rachael wrote:GZDoom does not run OpenGL in Software mode on anything below OpenGL 3.0.

For that it either uses Direct3D or whatever unaccelerated framebuffer the operating system will provide.


So it's going to crap out upon loading like a hardware 1.5 card does on the current gz build?

Re: Card that only supports "software mode" of opengl2 on gz

PostPosted: Thu Mar 15, 2018 9:17 am
by Rachael
It will not even start until you disable vid_glswfb in Windows.

On Linux it just does a fallback to unaccelerated SDL.

Re: Card that only supports "software mode" of opengl2 on gz

PostPosted: Thu Mar 15, 2018 6:30 pm
by drfrag
Just try. FX cards crashed on D3D with early drivers and ran only on DDraw on even earlier drivers. Early drivers had only GL 1.5 support, GL 2.0 support came later. It should work on the legacy render path, the old renderer works for sure.

Re: Card that only supports "software mode" of opengl2 on gz

PostPosted: Thu Mar 15, 2018 10:19 pm
by invictius
Rachael wrote:It will not even start until you disable vid_glswfb in Windows.

On Linux it just does a fallback to unaccelerated SDL.


A question that I may as well put here instead of another thread: when did older ATI cards start to have trouble with gz? I know when it stopped being an issue, just want to pick up a few cards from the 9000/x series if they're going to perform as well as similar vintage nvidia ones.

Re: Card that only supports "software mode" of opengl2 on gz

PostPosted: Fri Mar 16, 2018 2:22 am
by Kotti
ATI always had issues. I still remember the bad old times when I had such a card. Fog display on any ATI card before shaders was totally broken and glitchy and essentially had to be disabled. This was a driver bug which never got fixed. The other issue dating from these bad old times is the poor draw call performance. This has plagued ATI since the beginning of times and also never improved until today.

Re: Card that only supports "software mode" of opengl2 on gz

PostPosted: Mon Mar 19, 2018 5:31 am
by invictius
Kotti wrote:ATI always had issues. I still remember the bad old times when I had such a card. Fog display on any ATI card before shaders was totally broken and glitchy and essentially had to be disabled. This was a driver bug which never got fixed. The other issue dating from these bad old times is the poor draw call performance. This has plagued ATI since the beginning of times and also never improved until today.


Are there any versions where disabling shaders is not possible?

Re: Card that only supports "software mode" of opengl2 on gz

PostPosted: Mon Mar 19, 2018 6:16 am
by Graf Zahl
The shader was written for OpenGL 3.x compatible cards. Even the first iteration was entirely unusable on such old hardware. Even for one generation older there were several options that could be disabled, but as things stand, GLSL was not usable on pre-OpenGL 3 hardware. That was mainly an issue of GLSL, though, because it was written for more capable hardware . Microsoft's shading language was far less abstract and easier to use on GL 2 hardware.

I also remember making some tests on my old Geforce 6800, where even a full-scene invulnerability shader caused a significant performance breakdown. And that shader back then was as simple as they come, with no changing input aside from the vertices.

Re: Card that only supports "software mode" of opengl2 on gz

PostPosted: Mon Mar 19, 2018 7:39 am
by invictius
Graf Zahl wrote:The shader was written for OpenGL 3.x compatible cards. Even the first iteration was entirely unusable on such old hardware. Even for one generation older there were several options that could be disabled, but as things stand, GLSL was not usable on pre-OpenGL 3 hardware. That was mainly an issue of GLSL, though, because it was written for more capable hardware . Microsoft's shading language was far less abstract and easier to use on GL 2 hardware.

I also remember making some tests on my old Geforce 6800, where even a full-scene invulnerability shader caused a significant performance breakdown. And that shader back then was as simple as they come, with no changing input aside from the vertices.


So it's fair to say that Jdoom would have run significantly better than gz on your old 6800. Just asking as most of my dooming at that stage was jdoom, with models enabled (I didn't know models for GZ were a thing until about 2011)

Re: Card that only supports "software mode" of opengl2 on gz

PostPosted: Mon Mar 19, 2018 7:56 am
by Graf Zahl
What?

No. Even the current GZDoom in legacy mode runs circles around Doomsday engine. GZDoom just never activated its shaders on such old hardware - but even back in 2005 it was capable of actually PLAYING Phobos: Anomaly Reborn. Boom features nonwithstanding, Doomsday ran as a slideshow with several seconds per frame on those maps, if it didn't crash, that is. The problem with Doomsday lies elsewhere. The engine is very, very inefficiently designed, from the ground up, and that's exclusively on the CPU side. I completely lost track of what Doomsday is doing these days, it may have gotten better, but I doubt it.