Grey screen on zdoom 2.8.1 startup on mac

ZDoom LE, Pentium 133's, Windows 98, and DOS 3.1 all go here! A bygone era, of particular interest to some folks.

Grey screen on zdoom 2.8.1 startup on mac

Postby invictius » Mon Jul 17, 2017 12:12 pm

After the dialog box disappears the title screen is just grey (Menu sounds/music, mouse cursor visible and sounds as if it's changing options). On a powerpc 500 running tiger. It works fine on a powerpc 800 also running Tiger. The error is almost like when you run gzdoom on a dodgy video card that doesn't really support opengl. Not sure if qzdoom would work on such an archaic system.
invictius
 
Joined: 03 Aug 2012

Re: Grey screen on zdoom 2.8.1 startup on mac

Postby _mental_ » Tue Jul 18, 2017 12:20 am

ZDoom on macOS uses OpenGL to render software framebuffer to the screen.
ZDoom 2.7 should work as it relies on SDL 1. 2.8 requires SDL 2 and so cannot be built for PowerPC Macs.
_mental_
 
 
 
Joined: 07 Aug 2011

Re: Grey screen on zdoom 2.8.1 startup on mac

Postby invictius » Tue Jul 18, 2017 1:59 pm

_mental_ wrote:ZDoom on macOS uses OpenGL to render software framebuffer to the screen.
ZDoom 2.7 should work as it relies on SDL 1. 2.8 requires SDL 2 and so cannot be built for PowerPC Macs.


What was the latest version not to use fmod? I hear that really bogs things down, especially a 500mmhz powerpc...
invictius
 
Joined: 03 Aug 2012

Re: Grey screen on zdoom 2.8.1 startup on mac

Postby _mental_ » Wed Jul 19, 2017 12:20 am

If you meant MIDAS then there is no Mac version of it. Also ZDoom was ported to Mac OS X much later.
_mental_
 
 
 
Joined: 07 Aug 2011


Return to Legacy Discussion

Who is online

Users browsing this forum: No registered users and 1 guest