[Not a bug] Jump sound missing

Bugs that have been investigated and resolved somehow.

Moderator: GZDoom Developers

Jump sound missing

Postby Hirogen2 » Sat Nov 01, 2003 2:30 pm

IIRC one could hear a jump sound in 47i and before.
User avatar
Hirogen2
 
Joined: 19 Jul 2003
Location: Central Germany
Github ID: jengelh
Operating System: RedHat-like Linux (RHEL, Fedora, CentOS, etc) 64-bit
Graphics Processor: Intel (Modern GZDoom)

Postby SargeBaldy » Sat Nov 01, 2003 2:36 pm

yeah, you could. funny i hadn't noticed you can't anymore :P
User avatar
SargeBaldy
my password is grapefruit6
 
Joined: 15 Jul 2003
Location: Oregon

Postby Enjay » Sat Nov 01, 2003 2:39 pm

Are you guys sure about that? I just tried b33 - no jump sound.

A quick check in SNDINFO seems to indicate that the jump sound is allocated to a sound lump that doesn't exist. This makes sense to me. It allows you to add your own jump sounds if you wish (I have done, and it works fine in 2.0.52) but doesn't simply allocate an overly familiar Doom sound to the jumping action.

You do get the grunt sound when you land heavily from a jump. Maybe that's what you're remembering? Or maybe you had a sound WAD loaded for a while with a jump sound?
User avatar
Enjay
Everyone is a moon, and has a dark side which he never shows to anybody. Twain
 
 
 
Joined: 15 Jul 2003
Location: Scotland

Postby SargeBaldy » Sat Nov 01, 2003 2:56 pm

i remember a sound like "HUH" when you jumped, and it's not the same sound.you make when you land... odd.
User avatar
SargeBaldy
my password is grapefruit6
 
Joined: 15 Jul 2003
Location: Oregon

Postby randi » Sat Nov 01, 2003 3:14 pm

ZDoom has always had a jump sound defined in SNDINFO, but it has never provided the sound (dsjump). If you heard it before, that means you previously had a wad containing the sound loaded.
User avatar
randi
Site Admin
 
Joined: 09 Jul 2003

Postby Hirogen2 » Tue Nov 18, 2003 10:59 am

Anyone got a copy of something pre 2.0.47?
User avatar
Hirogen2
 
Joined: 19 Jul 2003
Location: Central Germany
Github ID: jengelh
Operating System: RedHat-like Linux (RHEL, Fedora, CentOS, etc) 64-bit
Graphics Processor: Intel (Modern GZDoom)

Postby Cyb » Tue Nov 18, 2003 11:51 am

knock yourself out (I also have a bunch more, all the way back to 27.cab)

http://cyb.vect.org:8080/misc/46.cab

you're wrong btw, zdoom never had a jump sound included, though if you fall down more than 24 units from your jump you make the 'oof' sound when you hit the floor. A loooong time ago (prolly 1.22 or before) I recall versions where you made the oof sound whenever you landed after jumping, regardless of the height you fall, but that's since been changed.
Cyb
 
Joined: 15 Jul 2003

Postby Xaser » Tue Nov 18, 2003 8:08 pm

Cyb wrote: A loooong time ago (prolly 1.22 or before) I recall versions where you made the oof sound whenever you landed after jumping, regardless of the height you fall, but that's since been changed.


It must have been before 1.22, because it worked fine then.
User avatar
Xaser
anarchivist
 
 
 
Joined: 20 Jul 2003


Return to Closed Bugs

Who is online

Users browsing this forum: No registered users and 0 guests