[Not a bug] Floor still not scrolling

Bugs that have been investigated and resolved somehow.

Moderator: GZDoom Developers

Floor still not scrolling

Postby Hirogen2 » Fri Oct 10, 2003 3:20 pm

Hi,

(In addition to the "solved" http://forum.zdoom.org/viewtopic.php?t=634)

so, the ACS command takes 4 args (Scroll_Floor(tag, dx, dy, sc)) and the line in the map still takes its 5 args as specified by The Reference (tag, bits, sc, dx, dy). The attached WAD doesnot work and I do not see why. I entered the values as they were requested in ZETH.
User avatar
Hirogen2
 
Joined: 19 Jul 2003
Location: Central Germany
Github ID: jengelh
Operating System: RedHat-like Linux (RHEL, Fedora, CentOS, etc) 64-bit
Graphics Processor: Intel (Modern GZDoom)

Postby randi » Fri Oct 10, 2003 3:27 pm

Your Scroll_Floor line's type is set as a displacement scroller, with speed determined by the line's length. Displacement scrollers will only scroll when the sector in front of the control line moves. Change the type to 0, and it will do what you probably want.
User avatar
randi
Site Admin
 
Joined: 09 Jul 2003

Postby Hirogen2 » Sun Oct 12, 2003 6:12 am

Yes ok. The boomref.txt puzzled me a bit, it was unclear about Displacement, and Accelerative as it says is not what I wanted. Thanks for clearing up.
User avatar
Hirogen2
 
Joined: 19 Jul 2003
Location: Central Germany
Github ID: jengelh
Operating System: RedHat-like Linux (RHEL, Fedora, CentOS, etc) 64-bit
Graphics Processor: Intel (Modern GZDoom)


Return to Closed Bugs

Who is online

Users browsing this forum: No registered users and 0 guests