Intermission background always gets tiled in Heretic

Bugs that have been investigated and resolved somehow.

Moderator: GZDoom Developers

Forum rules
Please don't bump threads here if you have a problem - it will often be forgotten about if you do. Instead, make a new thread here.
brick
Posts: 40
Joined: Fri Apr 30, 2021 10:22 am
Graphics Processor: nVidia (Modern GZDoom)

Intermission background always gets tiled in Heretic

Post by brick »

Intermission backgrounds are always tiling in Heretic, as seen in the attached images. The problem can be mitigated in some ways, the only way I've found to completely get rid of it is by switching to a non-widescreen resolution AND setting a 1.2 aspect ratio for intermission background (under Scaling Options). The tiling is dramatically visible if scaling is turned off. This is unique to intermission maps, other graphics (title screen, credits, E2 end still and E3 vertical scroller) all work fine. This is also unique to Heretic; Doom's intermission maps display just fine, and do not respond to the intermission aspect ratio at all, which they also didn't do in the past. So it seems that the Heretic maps are being treated as flats and being tiled just like the blue flat on the tally screen is.

Using GZDoom 4.8.1. The problem may have appeared in 4.8.0, I only noticed it today, but it definitely wasn't there in 4.7.1.
You do not have the required permissions to view the files attached to this post.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
Posts: 47995
Joined: Sat Jul 19, 2003 10:19 am
Location: Germany

Re: Intermission background always gets tiled in Heretic

Post by Graf Zahl »

fixed. The tiling flag from the summary screen stuck around for too long and made this one tile as well.

Return to “Closed Bugs”