[4.8.0] Umbra of Fate crashes at start up

Bugs that have been investigated and resolved somehow.

Moderator: GZDoom Developers

Forum rules
Please don't bump threads here if you have a problem - it will often be forgotten about if you do. Instead, make a new thread here.
User avatar
Xtyfe
Posts: 1470
Joined: Fri Dec 14, 2007 6:29 pm
Graphics Processor: nVidia with Vulkan support

[4.8.0] Umbra of Fate crashes at start up

Post by Xtyfe »

I started playing Umbra of Fate, however, the game crashed at start up. This happens only on Vulkan. It works just fine with OpenGL.

I have a crash report that I have attached.
You do not have the required permissions to view the files attached to this post.
dpJudas
 
 
Posts: 2861
Joined: Sat May 28, 2016 1:01 pm

Re: [4.8.0] Umbra of Fate crashes at start up

Post by dpJudas »

Please try again with 4.8.1
User avatar
Xtyfe
Posts: 1470
Joined: Fri Dec 14, 2007 6:29 pm
Graphics Processor: nVidia with Vulkan support

Re: [4.8.0] Umbra of Fate crashes at start up

Post by Xtyfe »

dpJudas wrote:Please try again with 4.8.1
I hadn't realized that dropped today. I just tested and it still crashes. The only difference is that 4.8.1 does not produce a report.
dpJudas
 
 
Posts: 2861
Joined: Sat May 28, 2016 1:01 pm

Re: [4.8.0] Umbra of Fate crashes at start up

Post by dpJudas »

You could at least be a bit more specific. It doesn't crash - it exits with a fatal error:

Execution could not continue.

Shader 'shaders/Desaturate.fp' could not be compiled:
ERROR: 0:1: 'binding' : sampler/texture/image requires layout(binding=X)
ERROR: 1 compilation errors. No code generated.

Looking at Desaturate.fp that's an error in the mod. Uniform and texture bindings should not be declared in the GLSL files as the C++ code needs to known how to set up the bindings. The only difference between OpenGL and Vulkan here is that the vulkan backend noticed and refused to run. OpenGL here just binds those uniforms to undefined locations and that happened to work by luck.
User avatar
Xtyfe
Posts: 1470
Joined: Fri Dec 14, 2007 6:29 pm
Graphics Processor: nVidia with Vulkan support

Re: [4.8.0] Umbra of Fate crashes at start up

Post by Xtyfe »

I'm sorry, I lack the technical knowledge to know the difference. If this is a bug with the mod itself, then I'm sure this can be disregarded.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
Posts: 47995
Joined: Sat Jul 19, 2003 10:19 am
Location: Germany

Re: [4.8.0] Umbra of Fate crashes at start up

Post by Graf Zahl »

viewtopic.php?f=290&t=65475

Return to “Closed Bugs”