[Not a bug] TeleportGroup bug

Bugs that have been investigated and resolved somehow.

Moderator: GZDoom Developers

TeleportGroup bug

Postby 4MaTC » Sat Oct 09, 2021 4:21 am

Hello!

I've encountered this bug while experimenting with teleportgroup action.

The problem is: when group of monsters gets teleported from source (unconnected to destination) sector they are aware (alerted) of player if player shot in this sector before using teleportgroup; even if there is no line of sight.

In version 4.6 it works as intended, in versions 4.7 and 4.8 this bug repeats.

Also, maybe you are aware of bug, that if teleport fog is true then actor angle keeps resetting to 0, but if fog is false then actor angle is unchanged.

So, i've made my own acs script (inside the wad) that uses SetActorPosition, instead of TeleportGroup, fog-angle problem is gone, but they keep teleporting awake if you shot in destination sector.

Replaces
MAP01.wad
udm format
You do not have the required permissions to view the files attached to this post.
User avatar
4MaTC
 
Joined: 05 May 2021
Discord: 4MaTC#3436

Re: TeleportGroup bug

Postby Graf Zahl » Sat Oct 09, 2021 4:42 am

Works fine for me. Have you by any chance changed the compatibility preset to something more 'classic'?
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: TeleportGroup bug

Postby 4MaTC » Sat Oct 09, 2021 5:08 am

Just deleted the *.ini file and now it works. And i feel dumb now...
But i can swear there was an issue i discribed, i wouldn't waste my whole day making new script, searching for the problem, reading wiki, before posting here. And comp option was "default".

Sorry for false alarm then, i guess.
User avatar
4MaTC
 
Joined: 05 May 2021
Discord: 4MaTC#3436

Re: TeleportGroup bug

Postby Enjay » Sat Oct 09, 2021 5:09 am

Works for me too. I start a game, fire my pistol, walk into the square, the imps appear and just stand facing the corners until I do something that will wake them up (e.g. fire again).
User avatar
Enjay
Everyone is a moon, and has a dark side which he never shows to anybody. Twain
 
 
 
Joined: 15 Jul 2003
Location: Scotland

Re: TeleportGroup bug

Postby Graf Zahl » Sat Oct 09, 2021 5:24 am

Considering that deleting the INI helped I am fairly certain it was the monster alert compatibility option that caused it.

In original Doom monsters alert sectors, not actors. and if a monster is in an alerted sector it'll wake up. And sectors never lose their alert status.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany


Return to Closed Bugs

Who is online

Users browsing this forum: No registered users and 0 guests