[User error] solved - gzdoom linux doom2.wad bug

Bugs that have been investigated and resolved somehow.

Moderator: GZDoom Developers

solved - gzdoom linux doom2.wad bug

Postby ramon.dexter » Tue Sep 07, 2021 2:47 am

When I try to start doom2.wad on gzdoom ubuntu, it crashed telling that "sprite SSWV D missing sprite rotations".
Well, inspection in slade reveals that the sprite rotations are in there. Also, this bug don't happen in gzdoom windows, which is pretty weird.

I even tried downloading several different doom2.wad, but all has the same error. Basically, I cannot run any wad, that is based on doom2.wad due to the error.
Last edited by ramon.dexter on Tue Sep 07, 2021 9:24 am, edited 1 time in total.
User avatar
ramon.dexter
rudebwoy
 
Joined: 20 Oct 2015
Location: Kozolupy, Bohemia
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: nVidia with Vulkan support

Re: gzdoom linux doom2.wad bug

Postby Rachael » Tue Sep 07, 2021 5:11 am

Which version of GZDoom are you using, from where? Did you compile it yourself? What compiler did you use? What Ubuntu are you using? This report does not have enough data to take any meaningful action.

It works fine for me, that's all I can say - so if there's a problem here we have to figure out what's different about our setups.
User avatar
Rachael
Admin
 
Joined: 13 Jan 2004
Discord: Rachael#3767
Twitch ID: madamerachelle
Github ID: madame-rachelle
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: nVidia with Vulkan support

Re: gzdoom linux doom2.wad bug

Postby m8f » Tue Sep 07, 2021 7:43 am

Run GZDoom from a terminal and post the output, please.
User avatar
m8f
dreamer
 
 
 
Joined: 29 Dec 2017
Location: Siberia (UTC+7)
Discord: m8f#0629
Github ID: mmaulwurff
Operating System: Debian-like Linux (Debian, Ubuntu, Mint, etc) 64-bit

Re: gzdoom linux doom2.wad bug

Postby ramon.dexter » Tue Sep 07, 2021 9:11 am

Rachael: gzdoom4.6.1, downloaded as a .deb package from zdoom.org.

m8f:
Here is terminal output: This happens when I try to load only doom2.wad
Code: Select allExpand view
dexter@VELES:~$ gzdoom
GZDoom g4.6.1 - 2021-07-25 07:49:24 -0400 - SDL version
Compiled on Jul 27 2021

OS: Ubuntu 20.04.3 LTS, Linux 5.11.0-27-generic on x86_64
M_LoadDefaults: Load system defaults.
/home/dexter/iWADs/HERETIC.WAD: Lump LINEDES contains invalid positioning info and will be ignored
/home/dexter/iWADs/HERETIC.WAD: Lump WIDEDEFS contains invalid positioning info and will be ignored
/home/dexter/iWADs/HERETIC.WAD: Lump SEATORS contains invalid positioning info and will be ignored
/home/dexter/iWADs/HERETIC.WAD: Lump VERTEXUS contains invalid positioning info and will be ignored
/home/dexter/iWADs/HERETIC.WAD: Lump EM9 contains invalid positioning info and will be ignored
/home/dexter/iWADs/HERETIC.WAD: Lump VGRTEXE contains invalid positioning info and will be ignored
W_Init: Init WADfiles.
 adding /opt/gzdoom/gzdoom.pk3, 634 lumps
 adding /opt/gzdoom/game_support.pk3, 2514 lumps
 adding /home/dexter/iWADs/DOOM2.WAD, 2956 lumps
 adding /opt/gzdoom/game_widescreen_gfx.pk3, 122 lumps
I_Init: Setting up machine state.
CPU Vendor ID: GenuineIntel
  Name: Intel(R) Core(TM) i5-2520M CPU @ 2.50GHz
  Family 6, Model 42, Stepping 7
  Features: SSE2 SSE3 SSSE3 SSE4.1 SSE4.2 AVX HyperThreading
V_Init: allocate screen.
S_Init: Setting up sound.
I_InitSound: Initializing OpenAL
  Opened device Vnitřní zvukový systém Analogové stereo
  EFX enabled
ST_Init: Init startup screen.
Checking cmd-line parameters...
S_InitData: Load sound definitions.
G_ParseMapInfo: Load map definitions.
Texman.Init: Init texture manager.
Invalid data encountered for texture DOOM2.WAD:VILEB1E1
Invalid data encountered for texture DOOM2.WAD:VILEB2E8
Invalid data encountered for texture DOOM2.WAD:VILEB4E6
Invalid data encountered for texture DOOM2.WAD:VILEN7
Invalid data encountered for texture DOOM2.WAD:VILEN8
Invalid data encountered for texture DOOM2.WAD:VILEO3
Invalid data encountered for texture DOOM2.WAD:VILEO8
Invalid data encountered for texture DOOM2.WAD:SSWVD6
Invalid data encountered for texture DOOM2.WAD:SSWVD8
Invalid data encountered for texture DOOM2.WAD:SSWVF0
Invalid data encountered for texture DOOM2.WAD:SSWVP0
Invalid data encountered for texture DOOM2.WAD:RP2_3
Invalid data encountered for texture DOOM2.WAD:W112_3
Invalid data encountered for texture DOOM2.WAD:WALL23_2
Invalid data encountered for texture DOOM2.WAD:WALL00_2
Invalid data encountered for texture DOOM2.WAD:WALL00_3
Invalid data encountered for texture DOOM2.WAD:WALL58_2
Invalid data encountered for texture DOOM2.WAD:WALL58_3
Invalid data encountered for texture DOOM2.WAD:RW7_3
Invalid data encountered for texture DOOM2.WAD:MWALL1_1
Invalid data encountered for texture DOOM2.WAD:WALL47_1
Invalid data encountered for texture DOOM2.WAD:WALL04_2
Invalid data encountered for texture DOOM2.WAD:RW15_1
Invalid data encountered for texture DOOM2.WAD:TP2_2
Invalid data encountered for texture DOOM2.WAD:TP7_2
Invalid data encountered for texture DOOM2.WAD:W102_2
Invalid data encountered for texture DOOM2.WAD:W92_2
Invalid data encountered for texture DOOM2.WAD:RSKY3
Invalid data encountered for texture DOOM2.WAD:SW11_1
Invalid data encountered for texture DOOM2.WAD:WALL47_2
Invalid data encountered for texture DOOM2.WAD:WALL47_5
Invalid data encountered for texture DOOM2.WAD:WALL47_3
Invalid data encountered for texture DOOM2.WAD:W96_1
Invalid data encountered for texture DOOM2.WAD:WOLF10
Unknown patch 'RP2_3' in texture 'BLODRIP3'
Unknown patch 'W112_3' in texture 'BRNSMALL'
Unknown patch 'WALL23_2' in texture 'FIREWALB'
Unknown patch 'WALL00_2' in texture 'GRAYBIG'
Unknown patch 'WALL00_3' in texture 'GRAYTALL'
Unknown patch 'WALL00_2' in texture 'GRAYTALL'
Unknown patch 'WALL58_2' in texture 'GSTFONT2'
Unknown patch 'WALL58_3' in texture 'GSTFONT3'
Unknown patch 'RW7_3' in texture 'MARBFAC4'
Unknown patch 'MWALL1_1' in texture 'MARBLE1'
Unknown patch 'WALL47_1' in texture 'METAL'
Unknown patch 'WALL04_2' in texture 'NUKEDGE1'
Unknown patch 'WALL04_2' in texture 'NUKEDGE1'
Unknown patch 'WALL04_2' in texture 'NUKEDGE1'
Unknown patch 'WALL04_2' in texture 'NUKEDGE1'
Unknown patch 'WALL04_2' in texture 'NUKEPOIS'
Unknown patch 'WALL04_2' in texture 'NUKEPOIS'
Unknown patch 'WALL04_2' in texture 'NUKEPOIS'
Unknown patch 'WALL04_2' in texture 'NUKEPOIS'
Unknown patch 'RW15_1' in texture 'PANEL1'
Unknown patch 'TP2_2' in texture 'PIPE2'
Unknown patch 'TP7_2' in texture 'PIPE4'
Unknown patch 'W102_2' in texture 'SKINCUT'
Unknown patch 'W92_2' in texture 'SKINLOW'
Unknown patch 'RSKY3' in texture 'SKY3'
Unknown patch 'SW11_1' in texture 'STARGR1'
Unknown patch 'WALL47_2' in texture 'SW1GARG'
Unknown patch 'WALL47_2' in texture 'SW1LION'
Unknown patch 'MWALL1_1' in texture 'SW1MARB'
Unknown patch 'TP2_2' in texture 'SW1PIPE'
Unknown patch 'WALL47_2' in texture 'SW1SATYR'
Unknown patch 'WALL47_2' in texture 'SW2GARG'
Unknown patch 'WALL47_5' in texture 'SW2GARG'
Unknown patch 'WALL47_2' in texture 'SW2LION'
Unknown patch 'MWALL1_1' in texture 'SW2MARB'
Unknown patch 'TP2_2' in texture 'SW2PIPE'
Unknown patch 'WALL47_2' in texture 'SW2SATYR'
Unknown patch 'WALL47_3' in texture 'SW2SATYR'
Unknown patch 'W96_1' in texture 'WOOD5'
Unknown patch 'W96_1' in texture 'WOOD5'
Unknown patch 'WOLF10' in texture 'ZDOORF1'
ParseTeamInfo: Load team definitions.
LoadActors: Load actor definitions.
script parsing took 226.84 ms
R_Init: Init Doom refresh subsystem.
DecalLibrary: Load decals.
M_Init: Init menus.
P_Init: Init Playloop state.
[==============================================================================================================================....]




Something weird is going on. Because when I start the same doom2.wad on my windows machine, everything works fine, even without the errors mentioned here. I don't understand.
edit: Now I tested other wads...It happens for doom2.wad, heretic.wad and hexen.wad. Strife1.wad and doom.wad works. What is going on?


EDIT2: CASE CLOSED. I AM COMPLETE IDIOT. I forgot the gzdoom loads iwads from different location, where the files were corrupt. Replaced the files and problem is gone. Thank you for your time.
User avatar
ramon.dexter
rudebwoy
 
Joined: 20 Oct 2015
Location: Kozolupy, Bohemia
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: nVidia with Vulkan support


Return to Closed Bugs

Who is online

Users browsing this forum: No registered users and 0 guests