[Fixed] Gamma correction not working in SoftPoly Renderer

Bugs that have been investigated and resolved somehow.

Moderator: GZDoom Developers

Gamma correction not working in SoftPoly Renderer

Postby erni945 » Fri Mar 12, 2021 6:08 am

As in the topic, the gamma change in the SoftPoly renderer does not work, even though I have it set to 0.75. I am using the latest release of GZDoom.
My graphics card is GeForce 820M

https://ibb.co/VS4Dd80
erni945
 
Joined: 21 Apr 2016
Location: Poland

Re: Gamma correction not working in SoftPoly Renderer

Postby drfrag » Fri Mar 12, 2021 6:19 am

This was never implemented, i forgot it didn't work.
User avatar
drfrag
Os voy a romper a pedazos!
Vintage GZDoom Developer
 
Joined: 23 Apr 2004
Location: Spain
Discord: drfrag#3555
Github ID: drfrag666

Re: Gamma correction not working in SoftPoly Renderer

Postby Rachael » Fri Mar 12, 2021 6:58 am

As far as I know none of the final presentation shaders were implemented.
User avatar
Rachael
Admin
 
Joined: 13 Jan 2004
Discord: Rachael#3767
Twitch ID: madamerachelle
Github ID: madame-rachelle
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: ATI/AMD with Vulkan Support

Re: Gamma correction not working in SoftPoly Renderer

Postby drfrag » Fri Mar 12, 2021 9:54 am

Do you think it's important? I never use it with my laptop screen, i mean with a CRT it would be a different thing.
User avatar
drfrag
Os voy a romper a pedazos!
Vintage GZDoom Developer
 
Joined: 23 Apr 2004
Location: Spain
Discord: drfrag#3555
Github ID: drfrag666

Re: Gamma correction not working in SoftPoly Renderer

Postby Rachael » Fri Mar 12, 2021 10:15 am

Yes, it is, but it's not absolutely critical. I'd say it's important enough to be worth doing if anyone were so inclined, but I am working on another project at the moment and can't do it myself (not to mention I only almost know my way around that system).
User avatar
Rachael
Admin
 
Joined: 13 Jan 2004
Discord: Rachael#3767
Twitch ID: madamerachelle
Github ID: madame-rachelle
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: ATI/AMD with Vulkan Support

Re: Gamma correction not working in SoftPoly Renderer

Postby drfrag » Wed Mar 24, 2021 7:56 am

We've made a PR. It's software but very fast, i'd say almost free at half native resolution on my laptop.
https://github.com/coelckers/gzdoom/pull/1351
User avatar
drfrag
Os voy a romper a pedazos!
Vintage GZDoom Developer
 
Joined: 23 Apr 2004
Location: Spain
Discord: drfrag#3555
Github ID: drfrag666


Return to Closed Bugs

Who is online

Users browsing this forum: No registered users and 1 guest