[Not a bug] Sound sequence cant be heared but still take channel [4.4.2]

Bugs that have been investigated and resolved somehow.

Moderator: GZDoom Developers

Forum rules
Please don't bump threads here if you have a problem - it will often be forgotten about if you do. Instead, make a new thread here.

Sound sequence cant be heared but still take channel [4.4.2]

Postby Apeirogon » Tue Oct 27, 2020 12:18 pm

Sound sequence attached to sector with script takes sound channel even if camera that can hear this sound is way to far away from sector with this sound sequence.

Load file and start new game. Right at the start you should hear "pistol shot" sound sequence attached to sector. Open console and type "stat sound". It would show that one channel currently busy by this "pistol shot" sequence. Now type in console "warp 30000 0 0" for example, or any other big numbers. After warping sound statistics will still shows that one channel currently still "play" something. It dosent looks right.
sec_seq_chan_bug.zip


Cant say is it a my error or engine bug, since sound sequence related functions dont documented well.
You do not have the required permissions to view the files attached to this post.
User avatar
Apeirogon
I have a strange sense of humour
 
Joined: 12 Jun 2017

Re: Sound sequence cant be heared but still take channel [4.

Postby Graf Zahl » Tue May 10, 2022 7:31 am

This is perfectly normal for looped sounds. They need to stick around in case the player gets close again.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany


Return to Closed Bugs

Who is online

Users browsing this forum: No registered users and 3 guests