[Addressed] [GZDoom/LZDoom] MAPINFO - compat_soundcutoff doesn't work

Bugs that have been investigated and resolved somehow.

Moderator: GZDoom Developers

Forum rules
Please don't bump threads here if you have a problem - it will often be forgotten about if you do. Instead, make a new thread here.

[GZDoom/LZDoom] MAPINFO - compat_soundcutoff doesn't work

Postby hfc2x » Sat May 30, 2020 10:48 pm

What says in the title. I'm trying to make a map that works a lot like vanilla, and for the most part, most MAPINFO-set compatflags work fine. However, compat_soundcutoff does not work whatsoever.

I attached a file that includes a MAPINFO lump that sets some compatflags for both E1M1 and MAP01 so anyone can test this. Load this and open either E1M1 or MAP01 in any IWAD, type ID(K)FA cheat, and fire a rocket. The explosion sound will play fully, even though the actor has ceased to exist long ago. This happens in both GZDoom v4.3.3 and LZDoom v3.85, but also happens in the most recent development versions.
You do not have the required permissions to view the files attached to this post.
User avatar
hfc2x
DoomEU is not dead, just inevitably headed for a Mordeth nomination.
 
Joined: 17 Aug 2009
Location: Chule

Re: [GZDoom/LZDoom] MAPINFO - compat_soundcutoff doesn't wor

Postby Graf Zahl » Fri May 06, 2022 2:09 am

Just checking this, you are right. The current sound backend never checks this CVAR. From the looks of it this got changed when ZDoom migrated from FMod 3.7 to FModEx 4.x, which was 14 years ago. Back then the entire sound mixing model was changed.
I'm sorry, but I do not see a good way to re-enable this option with the current sound mixing model so I'm just going to remove the option from the menu.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany


Return to Closed Bugs

Who is online

Users browsing this forum: No registered users and 1 guest