[Closed] (4.3.3) Gus midi Audio Issues

Bugs that have been investigated and resolved somehow.

Moderator: GZDoom Developers

Forum rules
Please don't bump threads here if you have a problem - it will often be forgotten about if you do. Instead, make a new thread here.

(4.3.3) Gus midi Audio Issues

Postby Ghostrider231 » Thu Feb 20, 2020 11:34 pm

When I was launching gzdoom 4.3.3 with gus as my midi device...
Any midi that is played under GUS will either be very deafeningly loud and glitchy or just plain mute.


Also yes, I've tested this in the latest dev builds, and it still happens there.

However If I launch an older version of gzdoom (ex: 4.1.3), the GUS audio works and sounds as intended. (Even though it doesn't sound exactly like doom 2 bfg's but whatever)

You can test this with base doom 2, doom, heretic, hexen, or etc. (Demo wads/pk3s aren't needed)

And both of these use the exact same gus audio setup.

Steps to how to repeat this issue:
1. Use the gus setup that I've provided. (if you already had gus installed and ready, than skip this step)
2. Launch Gzdoom (any IWAD that has midi songs, like doom 2)
3. Make sure GUS is your current midi device.
4. Start a new game. (Title music doesn't repeat)
5. The Entryway midi becomes very loud and glitchy. (If you are using 4.1.3, then it will sound normal)

Quicker method:
You can also use the "changemus d_runnin" command in the console. (Or whatever song is a midi file)



Examples:

(Gzdoom 4.1.3, Gus works as intended)



(Gzdoom 4.3.3, LOUD SOUND WARNING)


Ignore the error messages in the example videos, those messages aren't related to this issue.

The Gus setup used
User avatar
Ghostrider231
Eh.
 
Joined: 15 Aug 2014
Location: Here
Discord: https://discord.gg/TVR2qPE
Graphics Processor: nVidia (Modern GZDoom)

Re: (4.3.3) Gus midi Audio Issues

Postby Octavia Siddlehudging » Sat Mar 28, 2020 11:39 pm

I have the same issue but it also doesn’t work on 4.1.3.
Octavia Siddlehudging
 

Re: (4.3.3) Gus midi Audio Issues

Postby Rebecca Mollywill » Fri Jun 10, 2022 6:39 pm

It seems this issue was fixed as of gzdoom 4.8.0. Feel free to close this thread.

-Ghostrider231
Rebecca Mollywill
 


Return to Closed Bugs

Who is online

Users browsing this forum: No registered users and 3 guests