Page 1 of 1

gzdoom.pk3 keeps HacX 2.0 from starting

PostPosted: Wed Aug 14, 2019 7:58 am
by SiFi270

The download link would normally be here but it seems to be down for the time being, so here's a quick mirror.

EDIT: Accidentally linked to the same imgur picture shown above instead of the actual download thread.

Re: gzdoom.pk3 keeps HacX 2.0 from starting

PostPosted: Wed Aug 14, 2019 8:30 am
by Graf Zahl
Why was this made a terminal error in the first place...? :?

Re: gzdoom.pk3 keeps HacX 2.0 from starting

PostPosted: Thu Aug 15, 2019 7:50 am
by SiFi270
I'm not sure if you're asking me or wondering in general, but either way, I figured these additional details might help: I'm just trying to start it as a iwad, with nothing in autoload, and commenting out "defaultskill" in hacx2.wad's mapinfo still gives me the same result.

Re: gzdoom.pk3 keeps HacX 2.0 from starting

PostPosted: Thu Aug 15, 2019 8:00 am
by Graf Zahl
This comes from having two MAPINFOs defining a default skill 'normal'. Any sane implementation would let the second one override the first. This is a totally pointless error.

Re: gzdoom.pk3 keeps HacX 2.0 from starting

PostPosted: Fri Aug 16, 2019 8:11 am
by _mental_
Do you want to convert this error to a warning or to remove it altogether?

Re: gzdoom.pk3 keeps HacX 2.0 from starting

PostPosted: Fri Aug 16, 2019 1:21 pm
by Graf Zahl
I think it should be removed, although the error points to something being wrong that should be checked out first.

Re: gzdoom.pk3 keeps HacX 2.0 from starting

PostPosted: Sat Aug 17, 2019 4:01 am
by _mental_
Fixed in 7e9a777. The same MAPINFO was parsed twice.

Also, detection for multiple MAPINFO processing was added. Now useless error was removed as well.