[Won't change] [4.2.0] +RIPPER not working

Bugs that have been investigated and resolved somehow.

Moderator: GZDoom Developers

[4.2.0] +RIPPER not working

Postby Xavier Trothall » Wed Aug 14, 2019 7:36 am

The projectile enters its death state instead of ripping through a monster upon impact. Using example below, start a new game, equip a plasma rifle, and shoot at a monster. The projectile should rip through, but instead it just disappears (latter of which is due to a lack of death state, but you get the idea).

https://drive.google.com/open?id=1UiQdU ... liaDFVTIym
Xavier Trothall
 

Re: [4.2.0] +RIPPER not working

Postby Enjay » Wed Aug 14, 2019 7:54 am

It seems to be a conflict with the fact that your projectile also bounces. If I remove the bouncing property, the projectile rips as expected:

Image

I wonder if the bouncing fixes for 4.2.0 have affected this? I suspect so because in a pre-fix git build, the projectiles rip.
User avatar
Enjay
Everyone is a moon, and has a dark side which he never shows to anybody. Twain
 
 
 
Joined: 15 Jul 2003
Location: Scotland

Re: [4.2.0] +RIPPER not working

Postby Graf Zahl » Wed Aug 14, 2019 8:29 am

Bouncing will override ripping, if bouncing on actors is enabled. The recent change only added handling for one overlooked case when hitting an actor from above or below.
The solution would be to set the projectile to not bounce off actors.

Unfortunately this is all a very complex system where cause and effect are not fully in sync, so weird effects may happen.
User avatar
Graf Zahl
Lead GZDoom Developer
Lead GZDoom Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: [4.2.0] +RIPPER not working

Postby Xavier Trothall » Wed Aug 14, 2019 8:50 am

I only need them to bounce off of walls and floors/ceilings, so that's definitely an acceptable solution. Thank you.
Xavier Trothall
 

Re: [4.2.0] +RIPPER not working

Postby Sunbeam » Wed Oct 02, 2019 7:20 am

I just encountered the same problem in the newest version of GZDoom (4.2.1). I added
Code: Select allExpand view
-ALLOWBOUNCEONACTORS
-BOUNCEONACTORS

to my projectile actor definition which solved the issue. However as a note to anyone having the same problem: Make sure to add these flags AFTER defining any bounce type like this:
Code: Select allExpand view
BounceType Hexen

For me setting the flags before the bounce type did not work.
User avatar
Sunbeam
 
Joined: 09 Apr 2013

Re: [4.2.0] +RIPPER not working

Postby Ichor » Fri Oct 04, 2019 5:23 pm

Sunbeam wrote:I just encountered the same problem in the newest version of GZDoom (4.2.1). I added
Code: Select allExpand view
-ALLOWBOUNCEONACTORS
-BOUNCEONACTORS

to my projectile actor definition which solved the issue. However as a note to anyone having the same problem: Make sure to add these flags AFTER defining any bounce type like this:
Code: Select allExpand view
BounceType Hexen

For me setting the flags before the bounce type did not work.

You'd think that it wouldn't matter what the order was, but apparently it does. This fixes all of my problems, even the +BOSSRIP issue that I posted about the other day.
User avatar
Ichor
The fun cannot be halted
 
Joined: 23 Jul 2003

Re: [4.2.0] +RIPPER not working

Postby Graf Zahl » Sat Oct 05, 2019 12:04 am

The order matters because "BounceType" sets the BounceFlags to a preset, just like the 'monster' and 'projectile' properties do with other flags.
So, if you give it later, it will override the older operations.
User avatar
Graf Zahl
Lead GZDoom Developer
Lead GZDoom Developer
 
Joined: 19 Jul 2003
Location: Germany


Return to Closed Bugs

Who is online

Users browsing this forum: Awario [RSS], ltx71 [Bot], MSN [Bot] and 1 guest