[Fixed] GZDOOM 4.0.0+ crashes with soundpack v3 when using WILDMIDI

Bugs that have been investigated and resolved somehow.

Moderator: GZDoom Developers

GZDOOM 4.0.0+ crashes with soundpack v3 when using WILDMIDI

Postby Christsnatcher » Fri May 24, 2019 7:22 am

Hello,

since v4.0.0 GZDOOM crashes (Report is attached) when using the midipack v3 "mod" (https://www.moddb.com/addons/audiopack- ... and-gzdoom) and selecting WILDMIDI (all other devices work perfectly fine). The behavior is the same on all common iwads, and it's interesting: The game starts normal and THE SOUND PLAYS FLAWLESSLY, but right when the first melody ends the game crashes. The same happens when you have another device enabled, change it in menu to WILDMIDI and click another time as if you would want to select the next device entry. And it also happens when you're quick and click on "Restart sound" while the first melody is still running.

I've uploaded my entire setup for you to MEGA, maybe it helps: https://mega.nz/#!oVoUHaTB!BsgcWPYjcgOB ... oLv6UdZa3c

Thank you very much for looking into this issue!
Attachments
CrashReport.zip
(22.29 KiB) Downloaded 14 times
Christsnatcher
 
Joined: 16 Dec 2017
Discord: Christsnatcher#0665

Re: GZDOOM 4.0.0+ crashes with soundpack v3 when using WILDM

Postby Graf Zahl » Sun Aug 18, 2019 9:14 am

Fixed.

This was caused by some old cleanup cruft that has no use in GZDoom and should have been removed long ago. It only was causing problems now, because it interfered with the lifetime of an internal mutex lock.
User avatar
Graf Zahl
Lead GZDoom Developer
Lead GZDoom Developer
 
Joined: 19 Jul 2003
Location: Germany


Return to Closed Bugs

Who is online

Users browsing this forum: Semrush [Bot] and 1 guest