Page 5 of 5

Re: [GZDoom 4.1.2] Vulkan Crashes "AMD 400/500 Series"

PostPosted: Fri Jun 07, 2019 11:43 pm
by MasterBeavis
im just glad you narrowed it down more lol

Re: [GZDoom 4.1.2] Vulkan Crashes "AMD 400/500 Series"

PostPosted: Sat Jun 08, 2019 12:02 am
by Dwailing
MasterBeavis wrote:im just glad you narrowed it down more lol


You're the one who got me looking into Display settings, and you were right about it being something in post-processing. I just started trying settings until something broke, lol. You'd probably have gotten there. More than anything I'm glad I was able to corroborate the issue. Would have been bad if this got written off as just a problem with your hardware.

Re: [GZDoom 4.1.2] Vulkan Crashes "AMD 400/500 Series"

PostPosted: Sat Jun 08, 2019 12:11 am
by Rachael
Vulkan is disabled on the 32 bit builds, so that's why it doesn't crash. This doesn't really mean anything.

Re: [GZDoom 4.1.2] Vulkan Crashes "AMD 400/500 Series"

PostPosted: Sat Jun 08, 2019 12:16 am
by MasterBeavis
Rachael wrote:Vulkan is disabled on the 32 bit builds, so that's why it doesn't crash. This doesn't really mean anything.

Yea we already figured that out lol its Bloom in Post Processing with Vulkan thats causing it

Re: [GZDoom 4.1.2] Vulkan Crashes "AMD 400/500 Series"

PostPosted: Sat Jun 08, 2019 12:18 am
by dpJudas
Dwailing wrote:More than anything I'm glad I was able to corroborate the issue

Yes, thanks once again in confirming this bug report. And thanks for narrowing it down the bloom pass and seemingly related to load/save code (save game thumbnail, most likely). It will help figuring out what could be causing it.

Re: [GZDoom 4.1.2] Vulkan Crashes "AMD 400/500 Series"

PostPosted: Mon Jun 10, 2019 1:15 am
by dpJudas
Okay, I pushed a commit that I think may fix the issue reported here. Please test again with the next nightly build.

Re: [GZDoom 4.1.2] Vulkan Crashes "AMD 400/500 Series"

PostPosted: Mon Jun 10, 2019 2:47 am
by MasterBeavis

Re: [GZDoom 4.1.2] Vulkan Crashes "AMD 400/500 Series"

PostPosted: Mon Jun 10, 2019 2:52 am
by dpJudas
Oh well. I don't have a clue what is causing the crash then.

Re: [GZDoom 4.1.2] Vulkan Crashes "AMD 400/500 Series"

PostPosted: Mon Jun 10, 2019 3:33 am
by _mental_
With this fix I managed to reproduce the crash on Vega occasionally. It's somewhere inside vkCmdBeginRenderPass function.
Spoiler: Callstack

It doesn't happen with validation layers enabled though.

Re: [GZDoom 4.1.2] Vulkan Crashes "AMD 400/500 Series"

PostPosted: Mon Jun 10, 2019 2:17 pm
by dpJudas
I pushed another commit that may be the source to that BeginRenderPass crash.

Re: [GZDoom 4.1.2] Vulkan Crashes "AMD 400/500 Series"

PostPosted: Mon Jun 10, 2019 2:22 pm
by MasterBeavis

Re: [GZDoom 4.1.2] Vulkan Crashes "AMD 400/500 Series"

PostPosted: Tue Jun 11, 2019 1:44 am
by _mental_
Fixed for me as well.