[Won't fix] thing_projectile with T_ROCKET -> misplaced part

Bugs that have been investigated and resolved somehow.

Moderator: GZDoom Developers

thing_projectile with T_ROCKET -> misplaced particles

Postby cccp_leha » Mon Jan 05, 2004 10:06 pm

Sorry for the wierd title, but the shot should explain better. I called thing_spawn(2, T_ROCKET, 128, 3);

Image
User avatar
cccp_leha
Words are silver; silence is gold... so stfu.
 
Joined: 16 Jul 2003
Location: NJ, USA

Postby Graf Zahl » Tue Jan 06, 2004 4:14 am

Don't expect a missile to work correctly if it doesn't move.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany

Postby Hirogen2 » Tue Jan 06, 2004 8:05 am

Yet, if a missile stands still, particles are stlll generated -- at its tail. You can find out by shooting a rocket and then enabling Freeze mode.
User avatar
Hirogen2
 
Joined: 19 Jul 2003
Location: Central Germany
Github ID: jengelh
Operating System: RedHat-like Linux (RHEL, Fedora, CentOS, etc) 64-bit
Graphics Processor: Intel (Modern GZDoom)

Postby randi » Mon Jan 12, 2004 4:12 pm

The location of the trail is determined by which direction it is moving, not which direction it is facing. Not worth changing, IMO.
User avatar
randi
Site Admin
 
Joined: 09 Jul 2003

Postby cccp_leha » Mon Jan 12, 2004 4:33 pm

OK, you may proceed then. :)
User avatar
cccp_leha
Words are silver; silence is gold... so stfu.
 
Joined: 16 Jul 2003
Location: NJ, USA


Return to Closed Bugs

Who is online

Users browsing this forum: No registered users and 1 guest