[Fixed] Can't alter game rules via config files

Bugs that have been investigated and resolved somehow.

Moderator: GZDoom Developers

Can't alter game rules via config files

Postby Janizdreg » Thu Jan 01, 2004 10:01 am

Changing the game rules (aka the sv_x variables) by executing a config file in game via the console doesn't work.

Example:
-------------------
I've got a config file named dmpure.cfg in my ZDoom dir. It includes the following settings:
    sv_nofov 1
    sv_nofreelook 1
    sv_nojump 1
    alwaysapplydmflags 1
Then, I launch ZDoom & type "exec dmpure.cfg" in the console. The config is read, but the only setting that's applied is alwaysapplydmflags.
User avatar
Janizdreg
 
Joined: 01 Jan 2004
Location: Finland

Postby Hirogen2 » Thu Jan 01, 2004 3:41 pm

Have you tried exec'ing it when in "deathmatch 1" or "deathmatch 2" mode or when having additional bots (= coop)?
User avatar
Hirogen2
 
Joined: 19 Jul 2003
Location: Central Germany
Github ID: jengelh
Operating System: RedHat-like Linux (RHEL, Fedora, CentOS, etc) 64-bit
Graphics Processor: Intel (Modern GZDoom)

Postby Janizdreg » Thu Jan 01, 2004 5:41 pm

Tried. Didn't work.
Though now I noticed this: sv_nofov & sv_nofreelook didn't work but sv_nojump did...weird. Some work, some don't.
User avatar
Janizdreg
 
Joined: 01 Jan 2004
Location: Finland

Postby randi » Tue Jan 06, 2004 5:11 pm

Fixed.
User avatar
randi
Site Admin
 
Joined: 09 Jul 2003


Return to Closed Bugs

Who is online

Users browsing this forum: No registered users and 1 guest