[Duplicate] teleport acting strange with zdoom in custom map

Bugs that have been investigated and resolved somehow.

Moderator: GZDoom Developers

teleport acting strange with zdoom in custom map

Postby Anonymous » Mon Dec 29, 2003 11:46 pm

Hi,

I am kind of new to zdoom and i have made a wad that has a teleport in it.

It seems to work in normal doom95 and doom legacy but in zdoom for some reason it wont warp me. I'm not sure what i did wrong or if this has been discussed here before.

I made the wad for normal doom but then i converted it over to zdoom with the editor. I dont know why it needs to be different because the normal wads that i create for doom work in zdoom. this is the only problem i have ever had. The teleport.

i would appreciate any advise,
thanks
Anonymous
 

Postby cccp_leha » Mon Dec 29, 2003 11:54 pm

Post it here so it can be looked at.
User avatar
cccp_leha
Words are silver; silence is gold... so stfu.
 
Joined: 16 Jul 2003
Location: NJ, USA

Postby Anonymous » Tue Dec 30, 2003 1:33 pm

Anonymous
 

Postby Biff » Tue Dec 30, 2003 2:16 pm

First of all, the wad has not been converted. It's in standard doom format, and zdoom will play it. No doom, doom2 or heretic wad needs conversion for zdoom to play it, conversion to zdoom-hexen format is needed only if you intend to make use of zdoom's many advanced features.

The reason the teleport does not work is that you have no tag numbers on the teleport lines, which should be the same tag number as for the sector containing the teleport destination. I see three lines near the teleport destination with tag number 1, but no function for these lines. No tag at all on the teleport lines nor the teleport destination sector.

Doom95 and Legacy probably work with this wad only because there is a single teleport, so somehow the missing tag is overlooked.
User avatar
Biff
Caleb is back for a visit
 
Joined: 16 Jul 2003
Location: Monrovia, CA, USA

Postby Ty Halderman » Tue Dec 30, 2003 2:19 pm

Line special types 52 and 97 (which seem to be on your teleport lines) don't exist in Hexen mode of ZDoom. I see these as specials in ZDoom:

70:Teleport(1),
71:Teleport_NoFog(1,2),
74:Teleport_NewMap(2),
75:Teleport_EndGame(0),

I'd try types 70 and 75 for teleport and end-game respectively. You don't mention the editor you used to convert this, but the ZWadConv program should have converted those, I think. It's a confusing step to take, but well worth it due to the plethora of new features :)

[edit] (Note to self, see if Biff is browsing the forum before posting) [/edit]
User avatar
Ty Halderman
I'm free! ...or at least inexpensive.
... in loving memory ...
 
Joined: 17 Jul 2003
Location: New Orleans LA

Postby Anonymous » Tue Dec 30, 2003 5:19 pm

hello guys, thanks a lot for the info.

I had a bit of trouble getting that teleporter to work right, the only thing that i thought was strange is that it worked in the regular doom but not zdoom.

I should have spent more time figuring out how to make the teleporter right :). Ill fix it.

I'm still trying to get the elevators and switches to work properly as well. I'm used to other games like the quake series where it's a lot different. I did make some shadow warrior/duke 3d maps and they are a lot like doom in that you draw sectors and they have tags ect. I used build.exe and its a great editor.

I tried wad author for a while but there are some things that you cant do in that so now im using doom builder and i like that much better. Theres nothing really to hold you back in doom builder.

thanks again
Anonymous
 

Postby Xaser » Fri Jan 02, 2004 1:51 pm

Doom Builder > Wad Author*100
User avatar
Xaser
anarchivist
 
 
 
Joined: 20 Jul 2003

Postby randi » Fri Jan 02, 2004 9:59 pm

This is a duplicate of this bug and was already fixed in 2.0.60.
User avatar
randi
Site Admin
 
Joined: 09 Jul 2003


Return to Closed Bugs

Who is online

Users browsing this forum: No registered users and 1 guest